locked
Parameters for Multiple Subreports RRS feed

  • Question

  • Hello

    I have a report with 2 sub reports.  The 1st subreport is summary level data from a query, and the 2nd subreport is detail level data from the same query.  They are in rectangles in order to provide a page break between them when run.

    Anyway, when running the report, both summary and detail reports will need the same parameters.  I have set the parameters up and they work when the subreports are run as stand-alone reports, but when trying to run them together as part of the main report I get the "one or more parameters required to run the report have not been specified" error.

    Any suggestions?

    Thank you!


    Bonediggler
    Tuesday, August 9, 2011 7:34 PM

Answers

  • Figured it out

    Just set up parameters (even though not needed) on the main report, then pass them to the subreports via right click sub report > parameters > add parameters > then assign main report parameters as values

     

     

     


    Bonediggler
    • Proposed as answer by Sharp Wang Thursday, August 11, 2011 6:47 AM
    • Marked as answer by Sharp Wang Monday, August 22, 2011 6:07 AM
    Tuesday, August 9, 2011 8:29 PM

All replies

  • Figured it out

    Just set up parameters (even though not needed) on the main report, then pass them to the subreports via right click sub report > parameters > add parameters > then assign main report parameters as values

     

     

     


    Bonediggler
    • Proposed as answer by Sharp Wang Thursday, August 11, 2011 6:47 AM
    • Marked as answer by Sharp Wang Monday, August 22, 2011 6:07 AM
    Tuesday, August 9, 2011 8:29 PM
  • Figured it out

    Just set up parameters (even though not needed) on the main report, then pass them to the subreports via right click sub report > parameters > add parameters > then assign main report parameters as values

     

     

     


    Bonediggler
    Tuesday, August 9, 2011 8:29 PM