locked
HTML+CSS+JAVASCRIPT BASED win store app win app certification erro

    Question

  • Performance test
    FAILED
    Bytecode generation
    • Error Found: The bytecode generation test detected the following errors:
      • This package was deployed for development or authoring mode. Uninstall the package and re-install it normally.
    • Impact if not fixed:     As a performance optimization to accelerate JavaScript execution time, JavaScript files ending in the ".js" extension generate bytecode when the app is deployed. This optimization significantly improves start-up and ongoing execution times for JavaScript.  
    • How to fix: You may need consider one or more of these steps to fix the issue:
      - Ensure that event logging is enabled
      - All JavaScript files are syntactically valid; otherwise exclude the respective files from the package
      - Please note that you should uninstall all previous versions of the app before deploying
      Otherwise exclude the respective files from the package.
    Wednesday, August 14, 2013 6:31 PM

Answers

  • Make sure that the .js files are saved with UTF-8 encoding. That's what the cert check is complaining about.

    To verify and ensure the charset/encoding, open the file in Notepad, do File > Save As ..., and in that dialog pull down the Encoding drop-down at bottom. Make sure it's UTF-8, and if not, choose that and overwrite the file.

    This is a common failure if you're importing .js files (e.g. libraries) that might not have been saved as UTF-8. Visual Studio does it by default. (There is also an option in VS's Save As dialog for the same thing.)

    Wednesday, August 14, 2013 7:49 PM

All replies

  • The error message suggests how to fix that problem.

    If that isn't the issue you will need to provide more information about your specific scenario.

    --Rob

    Wednesday, August 14, 2013 6:39 PM
    Moderator
  • Make sure that the .js files are saved with UTF-8 encoding. That's what the cert check is complaining about.

    To verify and ensure the charset/encoding, open the file in Notepad, do File > Save As ..., and in that dialog pull down the Encoding drop-down at bottom. Make sure it's UTF-8, and if not, choose that and overwrite the file.

    This is a common failure if you're importing .js files (e.g. libraries) that might not have been saved as UTF-8. Visual Studio does it by default. (There is also an option in VS's Save As dialog for the same thing.)

    Wednesday, August 14, 2013 7:49 PM