Windows Media Player error code c00d11d2




    I need desperate help. When I tried to play any of my stored media files I would get an error code each time is a different one but most of the times the message that I get is this; "Windows Media Player cannot access the file. The file might be in use, you might not have access to the computer where the file is stored, or your proxy settings might not be correct. " I have tried everything, I can assured that my proxy settings don't have anything to do with it. Something is going on, I even called my laptop manufacturer and they just told me to send the computer in and for that I have to pay, a lot!

    Please help me. If it is of any help my operating system is Vista.

    • Moved by The March Hare Tuesday, September 15, 2009 6:07 AM not about Media Foundation SDK (From:Media Foundation Development)
    Friday, October 26, 2007 11:17 PM


All replies

  • Yup, sounds like something on your box is genuinely horked.  You might want to try the WMP newsgroup (, but I'm going to guess that there's a broader problem here and you might need to go the support route.

    Monday, October 29, 2007 1:20 PM
  • Hey, there.

    Thank you for your comment, but I already try the newsgroup and no one has answered.  


    Monday, October 29, 2007 5:18 PM
  • This helped me out with the same issue.
    Wednesday, October 31, 2007 1:34 AM
  • Hi cathy the problem is that your sound scheme has not been saved. Go into control panel and find your sounds and audio devices icon. Then go to "sounds" and save the scheme as anything you want. Then load that scheme back up and log off then back on. Now try your files again. Hope this helps as it fixed mine!!!


    Sunday, November 11, 2007 6:04 AM
  • OMG!!!! i love you. it worked. you=amazing.
    Friday, November 16, 2007 2:58 AM
  • wow that was weird, how the heck did you know that? it worked. never would've thought to do that.


    Friday, December 07, 2007 9:12 PM

    chit, this worked flawlessly.




    I cannot believe the amount of work just to end up doing that and it working.




    I think I am taking today off and staying home drinking because I failed at life.




    Thanks for helping out Ben.

    Tuesday, December 18, 2007 5:29 PM
  • i got a new vista home premium OS with a pc i got in oct. '07, and in nov. my wmp went out, giving error code c00d11d2 error messages, everytime i tried playing either cds, or dvds. i tried for a couple weeks to get it going, until i read in one of the blogs, to reinstall the OS, with the disc that came with my pc. it took a few hours to complete the reinstallation, not having to uninstall it first, too. after completion i tried my cd player, it worked, and my dvds too. one way to fix the error code is reinstallation of the OS. it fixed my prob. reistallation will not interrupt any files already in your pc, even such things as passwords and such. i relogged with my original password to get it going again


    Thursday, January 03, 2008 4:22 AM
  • Hey Thanks for the advise. I too had the same issue as Cathy. I didn't have to restart my computer it work right away. I contacted dell and they wanted me to whipe out the system and start over. Thank you so much. I figured there was an easier fix then starting all over again. I wish the techs at dell went to the forums to check out what people have figured out.
    Monday, January 07, 2008 4:15 AM

    For 2 days I have been trying to fix this problem. Even got sucked into buying a "clean up" software....frustrated, I kept clicking sites...and thank god for this one....fixed it at once...I am now backing everything up....thank you so much, are a genius!!!!!


    Saturday, January 12, 2008 6:41 PM

    dude, i love you. Seriously, i thought i would have to reinstall my OS. oh god, i am so happy!!
    Monday, January 28, 2008 5:08 AM

    Windows Media Player error code c00d11d2
    Friday, April 04, 2008 9:49 AM
  • I tried but am not sure how to "load that scheme back up"?  Can anybody explain the steps?  I have been trying to fix the problem for a day.  Please kindly help.


    Friday, August 22, 2008 4:18 PM
  • Here's the Fix ....


    Select all ur files in your folder, right click, then scroll down to share, click on share

    in the "file sharing" window, click the arrow on the drop down list, select "Everyone" (All Users), Click on the "ADD" button

    Change the Permission Level to the level u want, in this case, co-owner,   Click on the "share" button at the bottom and you're done ......


    Enjoy ur music and F*** Vista DRM

    Monday, October 06, 2008 6:14 AM
  • Thanks so much for this post. Really saved me a lot of bother.
    Tuesday, October 21, 2008 8:45 AM
  • Hello everybody

    I was having the same problems, what what worked for me was to open up control panel, then go to my sounds section... immediately after opening it i was prompted that the drivers for my speakers were causing errors. Then I disabled the bad ones and all was well.


    hope this helps



    Sunday, November 30, 2008 4:52 AM
  • None of this advice is helpful.  any other bright ideas.
    Tuesday, September 15, 2009 6:04 AM