locked
White screen debug? RRS feed

  • Question

  • isnt this nice! i've updated my app on IIS (just added one more report - devexpress 11.1.7 and LS v1), and also one field is manually changed in database and LSML file (external datasource, one field changed from nvarchar(4) to nvarchar(400) in one table - i've done this things before without consequences), well now its just white screen, without login or anything.. BUT on my machine everything works fine, even connected to live data from VS (over VPN).. does anyone had similar error (and solution) cause this is another show stopper, app is restored from backup so currently it works with old version, but this is stupid and i cant catch it..

    don't know, but this LS-thing starts to getting on my nerve more and more.. im constantly frustrated to do anything new with my app in fear that something would stop working.. any advice..? thanks in advance.. 

    Kivito


    Nobody expects the Spanish Inquisition! (M.P.F.C.)

    Thursday, January 31, 2013 8:56 AM

Answers

  • thanks for suggestions!
    after couple days "on hold", i tried again with publishing of my app.. it seems that devex reports are little buggy on memory consumption (at least on my system - it's not rare that building procedure exits with out of memory exception), so after restarting machine, cleaning and rebuilding solution, publish went fine and my app has started normally.. sometimes this "little things" can drive you mad (specially when you have to wait for about an hour for upload to complete and to actually test it on server).. just by observing from which point all gone wrong, it is very easy to be misleaded on a "false clue"..

    @Yann - i would gladly update datasource (and im doing it on smaller databases), but this database is huge and i cannot store it locally, and updating schema over VPN lasts forever with tendency to break, so in cases like this i try to manual edit of lsml.. i know that this is not recommended, but i dont have many choices..

    again, thanks for help!

    Kivito


    Nobody expects the Spanish Inquisition! (M.P.F.C.)

    • Marked as answer by Kivito Thursday, February 7, 2013 4:17 PM
    Thursday, February 7, 2013 4:16 PM

All replies

  • Hi Kivito,

    Try to enable some option for produce some detail errors and logs for debugging purpose.

    You can read the steps from these articles:

    - LightSwitch desktop app shows white screen

    - Diagnosing Problems in a Deployed 3-Tier LightSwitch Application (Eric Erhardt)

    - Just get blank screen


    Regards,
    Christian HL
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, February 7, 2013 3:36 AM
  • You might like to consider using an attached database in any future projects. I haven't used the intrinsic database  for quite some time now, & I'm constantly updating my schema etc, without any problems.

    Yann - LightSwitch Central - Click here for FREE Themes, Controls, Types and Commands
     
    Please click "Mark as Answer" if a reply answers your question. Please click "Vote as Helpful" , if you find a reply helpful.
     
    By doing this you'll help others to find answers faster.

    Thursday, February 7, 2013 8:38 AM
    Moderator
  • thanks for suggestions!
    after couple days "on hold", i tried again with publishing of my app.. it seems that devex reports are little buggy on memory consumption (at least on my system - it's not rare that building procedure exits with out of memory exception), so after restarting machine, cleaning and rebuilding solution, publish went fine and my app has started normally.. sometimes this "little things" can drive you mad (specially when you have to wait for about an hour for upload to complete and to actually test it on server).. just by observing from which point all gone wrong, it is very easy to be misleaded on a "false clue"..

    @Yann - i would gladly update datasource (and im doing it on smaller databases), but this database is huge and i cannot store it locally, and updating schema over VPN lasts forever with tendency to break, so in cases like this i try to manual edit of lsml.. i know that this is not recommended, but i dont have many choices..

    again, thanks for help!

    Kivito


    Nobody expects the Spanish Inquisition! (M.P.F.C.)

    • Marked as answer by Kivito Thursday, February 7, 2013 4:17 PM
    Thursday, February 7, 2013 4:16 PM
  • You're welcome.

    Yann - LightSwitch Central - Click here for FREE Themes, Controls, Types and Commands
     
    Please click "Mark as Answer" if a reply answers your question. Please click "Vote as Helpful" , if you find a reply helpful.
     
    By doing this you'll help others to find answers faster.

    Friday, February 8, 2013 12:01 AM
    Moderator