locked
How to increase session timeout to 8 to 9hrs? RRS feed

  • Question

  • User230766423 posted

    Hello All,

    I tried to increase the session timeout to 8 to 9hrs(means 8*60) but still timeout occurs earlier

    Whats the other way to increase the timeout?

    Tuesday, July 1, 2008 7:06 AM

All replies

  • User1723862003 posted

    Hi there,

    That needs to be done at the IIS level on the hosting server.

    Tuesday, July 1, 2008 7:28 AM
  • User537870505 posted

    Where did you set the timeout? web.config or IIS management console? Set it in web.config if for an ASP.NET app. Also, you may have to set the app pool idle timeout to 9 hrs if using IIS 6.

    Tuesday, July 1, 2008 7:31 AM
  • User-950290215 posted

    Include this in you web.config file:

    <system.web>
            <sessionState timeout="540"/>

    ... 

     

    Hope this would help. 

    Tuesday, July 1, 2008 7:34 AM
  • User1723862003 posted

    Hi,

    the procedure is as below.

    Change the following time-outs in Internet Services Manager .Choose a value greater than the default of 20.

      1. Select Default Web Site > Properties > Home Directory > Application Settings > Configuration > Options.

      2. Enable the session state time-out and set the Session timeout for 60 minutes.

      3. Select Application Pools > DefaultAppPool > Properties.

      4. From the Performance tab under Idle timeout, set Shutdown worker processes after being idle for a value higher than 20.

    The default session time-out setting on IIS is 20 minutes but it can be increased to a maximum of 24 hours or 1440 minutes. See Microsoft article Q233477 for details about increasing the timeout in IIS.

    Symptom

    When returning to the logon page for Web Interface, users often encounter an Error: Your session with the web-server expired. You have been logged out.

    Cause

    Web Interface 2.0 picks up the session timeout setting from IIS.

    Resolution

    1. Start Internet Services Manager 5.0.

    2. For explicit authentication, right-click the /Citrix/MetaFrameXP/default virtual directory and view the Properties.

      For desktop credentials, pass-through users edit the /Citrix/MetaFrameXP/integrated virtual directory.

    For Smart Card users, edit the /Citrix/MetaFrameXP/certificate virtual directory.

    3. In the Application Settings section, click Configuration.

    4. Select the App Options tab.

    5. Ensure Enable session state is selected.

    The default session time-out setting on IIS is 20 minutes but it can be increased to a maximum of 24 hours or 1440 minutes. See Microsoft article Q233477 for details about increasing the timeout in IIS.

    NFuse Classic 1.71 and earlier

    When Internet Explorer is configured never to check for newer versions of Web pages, NFuse Classic will not launch an application after a session is allowed to expire. To reproduce this problem:

      1. Configure your browser settings for 'Temporary Internet files and set Check for newer versions of stored pages to Never.

      2. Log on to Citrix NFuse Classic and view your published applications.

      3. Leave the system idle for 20 minutes or longer so that the Web server session expires.

      4. Click an application icon. The system returns you to the Logon page and a message appears stating that your session expired.

      5. Log on again and click the same application as before. You are again returned to the Logon page even though your session should not have expired this time.

    Solutions

        • Clear the Temporary Internet Items folder

        • Upgrade to Web Interface 2.0 or later

        • Set Check for Newer versions of stored pages to Automatically

    The default session time-out setting on IIS is 20 minutes but it can be increased to a maximum of 24 hours or 1440 minutes. See Microsoft article Q233477 for details about increasing the timeout in IIS.

    NFuse 1.6

    This error is caused by the expiration of a Web server session, not a MetaFrame ICA session. Web servers maintain session state for a fixed time period to preserve Web server resources and as a security precaution. The default setting for IIS is 20 minutes. Do not remove this timeout. However, the timeout can be modified in the following ways (assuming your Web server is Microsoft IIS):

      1. Open Internet Services Manager.

      2. From the Web site Properties, click the Home Directory tab, then click the Configuration... button in the Application Settings section.

      3. On the configuration panel, click the App Options tab and set the session timeout there.

      4. In NFuse 1.6, add this line to the end of redirect.asp:

      <% Session.Timeout = 20%>

      where 20 is the number of minutes after which an idle session will time out.

    Increasing this value improves usability, preventing users from having to enter their credentials too frequently.

    Decreasing this value improves security; if a user leaves his desk unattended with the NFuse application list showing, other users can launch applications using the account. The session time out acts as an idle time out and prevents this type of abuse.


     

    Tuesday, July 1, 2008 7:36 AM
  • User-1346602782 posted

    Hello All,

    I tried to increase the session timeout to 8 to 9hrs(means 8*60) but still timeout occurs earlier

    Whats the other way to increase the timeout?

    Hope your problem must have been solved by kalyan's posting.

    I think it may solve ur problem.

    Tuesday, July 1, 2008 8:03 AM
  • User1048247244 posted

      It's already been posted how to increase it, but may I ask why that long? In my opinion, any data that needs to be stored for more than 30 minutes should go into a cookie, or if space is a concern a database or xml entry should be created.

    Tuesday, July 1, 2008 5:07 PM
  • User230766423 posted

    thanks guys

    my problem has been solved by kalyan's post

    but to save the server memory if i tried to use the cookies..i get into the same loop

    Wednesday, July 2, 2008 7:38 AM
  • User-1088151413 posted

    use sessiontimeout="15"

    fixed number of minutes and after that this session will dynamically removed from server 

    Wednesday, July 2, 2008 9:14 AM
  • User356016245 posted

     

    Thanks,

    the info you provided here helped me to solve the problem. It works :)

    Monday, March 2, 2009 6:04 AM
  • User-1941489749 posted

     yes u r wright. but how can i increase session  timout without changing any server IIS setting.

    Monday, July 27, 2009 8:05 AM
  • User1124534712 posted

    <sessionState mode="InProc" stateNetworkTimeout="10" sqlCommandTimeout="30" cookieName="ASP.NET_SessionId" timeout="53200" regenerateExpiredSessionId="False">
                <providers>
                    <clear/>
                </providers>
            </sessionState>
        </system.web>

    Wednesday, August 12, 2009 2:05 AM
  • User-623202070 posted

    Hello Kalyan

    I m using asp.net and my sql( easyPHP 3.1),

    can u know How to increase session timeout to 8 hours to 10 hours in this case

    Wednesday, August 12, 2009 4:17 AM
  • User-481631678 posted

    Refer to this article for solution to your problem.

    http://www.brainbell.com/tutorials/ASP/Configuring_Session_State.html

    In case you are not using SQL server as database then you can use asp.net state service to manage session state

    Tuesday, August 18, 2009 10:08 AM
  • User283171096 posted

    Every one given you different view ans answer .

    if all option are fail then just contact to you server hostage he will increase you time that much you want

    i also face this problem

    Thanks    ................

    Thursday, August 20, 2009 8:18 AM
  • User4747630 posted

    But that increases timeout for all apps on the web server. Using web.config approach is surely more finely grained and a better aproach.

    Monday, April 26, 2010 7:10 PM
  • User2118976055 posted

    Hi Swati Jain,

    If you are using web.config to set the session timeout   use below code(means 9*60)

    <system.web>
            <sessionState timeout="540"/>

    If you are using IIS set the above value in that.

    Tuesday, April 27, 2010 8:57 AM
  • User1682995268 posted
    One more Question Mr.Kalyan Is it possible to set time for one particular Session Variable ( Ex. Session["Ex"] )
    Monday, March 14, 2011 2:44 AM
  • User-481631678 posted

    No you can not change the timeout for only one particular variable in session.

    Monday, March 14, 2011 5:41 AM
  • User239733016 posted
    Dear, User these options: 1. sessionState 2. Cookie 3. Alter from IIS
    Wednesday, March 16, 2011 4:45 AM