locked
Search doesn't return any results RRS feed

  • Question

  • Indexing is on and working but search doesn't return any results. What can be the reason and how to fix it?
    Wednesday, October 29, 2014 10:11 AM

Answers

  • Thanks for all the replies and suggestions!

    The problem is solved and it was about server Proxy settings which were preventing the crawler's connection to the content source (and its starting addresses).

    Finally there was also a new error type for sps3:// starting address for the person search. That was solved By adding search account as an administrator in User Profile Service.

    • Marked as answer by Freedomic Monday, November 17, 2014 12:31 PM
    Monday, November 17, 2014 12:31 PM

All replies

  • Have you configured Global search center URL inside your search service application?

    Thank You, Pallav S. Srivastav ----- If this helped you resolve your issue, please mark it Answered.

    Wednesday, October 29, 2014 10:22 AM
  • Have you configured Global search center URL inside your search service application?

    Thank You, Pallav S. Srivastav ----- If this helped you resolve your issue, please mark it Answered.

    I did it now, it was wrong in the Application settings.

    I also added search center URL in Site settings > Search Settings >.

    But these don't help.

    Wednesday, October 29, 2014 10:45 AM
  • Hello Free..

    first go to search service application from Central Administration >> Application Management >> Service applications >> search service application. see bellow couple of point.

    1) see content sources your web application url must be there in at least one content source. if not there please add.

    2) you can also add a new content source and add your web application.

    3) full crawl the content source in which your web application is included.

    4) once you crawl as you have already done with the search center settings you will definitely see search results.

    you can also check the search services is started in manage services on the service


    Mukesh

    Wednesday, October 29, 2014 11:05 AM
  • Hello Freedomic,

    Can you try doing it using Powershell

    http://blogs.technet.com/b/speschka/archive/2012/10/29/how-to-configure-the-global-search-center-url-for-sharepoint-2013-using-powershell.aspx


    Thanks and Regards Rahul Dagar

    Wednesday, October 29, 2014 11:05 AM
  • Goto Search service application and please provide what is the status of your "Crawler background activity"

    Thank You, Pallav S. Srivastav ----- If this helped you resolve your issue, please mark it Answered.

    Wednesday, October 29, 2014 11:16 AM
  • Hello Free..

    first go to search service application from Central Administration >> Application Management >> Service applications >> search service application. see bellow couple of point.

    1) see content sources your web application url must be there in at least one content source. if not there please add.

    2) you can also add a new content source and add your web application.

    3) full crawl the content source in which your web application is included.

    4) once you crawl as you have already done with the search center settings you will definitely see search results.

    you can also check the search services is started in manage services on the service


    Mukesh

    These are done and ok but it doesn't help.
    Wednesday, October 29, 2014 11:17 AM
  • Hello Freedomic,

    Can you try doing it using Powershell

    http://blogs.technet.com/b/speschka/archive/2012/10/29/how-to-configure-the-global-search-center-url-for-sharepoint-2013-using-powershell.aspx


    Thanks and Regards Rahul Dagar

    I have already done this in Central Administration > Search Application.
    Wednesday, October 29, 2014 11:17 AM
  • Please reply to this.

    Thank You, Pallav S. Srivastav ----- If this helped you resolve your issue, please mark it Answered.

    Wednesday, October 29, 2014 11:24 AM
  • Any other ideas?
    Wednesday, October 29, 2014 12:46 PM
  • Goto Search service application and please provide what is the status of your "Crawler background activity"

    Thank You, Pallav S. Srivastav ----- If this helped you resolve your issue, please mark it Answered.

    Thursday, October 30, 2014 3:07 AM
  • The status of Crawler background activity is "None".

    Searchable items is 0. It used to be 1. I have documents in libraries.

    • Edited by Freedomic Thursday, October 30, 2014 6:21 AM
    Thursday, October 30, 2014 6:06 AM
  • Hi Freedomic

    Can you paste your Topology like the below one.

    Administrative status Running
    Crawler background activity None
    Recent crawl rate 0.00 items per second
    Searchable items 0
    Recent query rate 0.00 queries per minute
    Default content access account domain/administrator
    Contact e-mail address for crawls
    Proxy server for crawling and federation None
    Search alerts status
    On  Disable
    Query logging
    On  Disable
    Global Search Center URL Set a Search Center URL


    Thanks and Regards Rahul Dagar

    Thursday, October 30, 2014 6:22 AM
  • if searchable items  is 0 that is why it doesn't work.

    To add it, select "Content sources" on the left and add a new one.


    Thanks and Regards Rahul Dagar

    Thursday, October 30, 2014 6:30 AM
  • Administrative status

    Running
    Crawler background activity None
    Recent crawl rate 0.21 items per second
    Searchable items 0
    Recent query rate 1.00 queries per minute
    Default content access account MYDOMAIN/SP_Content
    Contact e-mail address for crawls SP_Farm@mydomain.name
    Proxy server for crawling and federation None
    Search alerts status
    On  Disable
    Query logging
    On  Disable
    Global Search Center URL

    http://my.domain.name/SearchCenter/Pages

    Searchable items used to be 1 yesterday.


    • Edited by Freedomic Thursday, October 30, 2014 6:41 AM
    Thursday, October 30, 2014 6:38 AM
  • select "Content sources" and add a new one.

    Thanks and Regards Rahul Dagar

    Thursday, October 30, 2014 6:42 AM
  • Please reset your index and start full crawl on a new content source again.

    If you are crawling HTTPS site, then please add the certificate in manage trust under Central Administration.


    Thank You, Pallav S. Srivastav ----- If this helped you resolve your issue, please mark it Answered.

    Thursday, October 30, 2014 6:59 AM
  • select "Content sources" and add a new one.

    Thanks and Regards Rahul Dagar

    I have already a working Content Source. In crawl (indexing) log of this content source there is 58 successful hits.

    • Edited by Freedomic Thursday, October 30, 2014 7:25 AM
    Thursday, October 30, 2014 7:07 AM
  • I reseted index and made a full crawl on my existing Content Source. Now the indexing history shows 0 succesful hits. Searchable items is also 0.

    I don't use https.

    If indexing fails to search, what to do?

    Thursday, October 30, 2014 7:33 AM
  • are you able to search the content now ? can you post the crawl results ? or you can use below toll to search the results : https://sp2013searchtool.codeplex.com/


    Subhash

    Thursday, October 30, 2014 7:34 AM
  • are you able to search the content now ? can you post the crawl results ? or you can use below toll to search the results : https://sp2013searchtool.codeplex.com/


    Subhash

    No, I'm not able to search content and that's because Searchable items remains 0, and also successful hits is 0 in crawl history.

    I made a full crawl half an hour ago, after that there has been 2 incremental crawls.

    Thursday, October 30, 2014 7:54 AM
  • What error do you see in Crawl Log?

    Thank You, Pallav S. Srivastav ----- If this helped you resolve your issue, please mark it Answered.

    Thursday, October 30, 2014 7:59 AM
  • Hi Freedomic,

    Can you remove and re-add the content source.


    Thanks and Regards Rahul Dagar

    Thursday, October 30, 2014 8:12 AM
  • Please provide screenshot of your crawl log

    Thank You, Pallav S. Srivastav ----- If this helped you resolve your issue, please mark it Answered.

    Thursday, October 30, 2014 8:18 AM
  • What error do you see in Crawl Log?

    Thank You, Pallav S. Srivastav ----- If this helped you resolve your issue, please mark it Answered.

    There are 3 errors in Crawl Log. Their content is

    "Crawl couldn't exchange information with the server. Check that the server is available and the firewall settings are configured ok."

    Thursday, October 30, 2014 8:22 AM
  • Hello,

    Can you check if the account "MYDOMAIN/SP_Content" is ok? (not locked, password ok, etc)

    If the password has changed, maybe you need to restart yoru SharePoint server


    Best regards, Christopher.
    Blog | Mail
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.
    Why mark as answer?

    Thursday, October 30, 2014 8:23 AM
  • Hi Freedomic,

    Can you remove and re-add the content source.


    Thanks and Regards Rahul Dagar

    Yes I can but is it worth it, I wonder. Because the it seems to be correctly configured. It includes the site collections that I'm operating with.
    Thursday, October 30, 2014 8:24 AM
  • Hi Freedomic,

    Have you checked what Christopher requested for?

    Yes, it is worth.


    Thanks and Regards Rahul Dagar

    Thursday, October 30, 2014 8:51 AM
  • Are Windows Firewall on your server disabled?

    Also, if you are using Host Header then, is the binding correctly configured in IIS and AAM.

    Try to make a host entry update on your APP server where search is configured and then try to perform index reset and full crawl.


    Thank You, Pallav S. Srivastav ----- If this helped you resolve your issue, please mark it Answered.

    Thursday, October 30, 2014 8:58 AM
  • Hi,

    Please make sure the content access account of the search service application with read permission on web applications

    Please make sure Search Service Application connection properly.

    Open Central Admin > Application Management > Manage web applications > Select your applications > Select Service Connections from top ribbon > Make sure your Search service application is selected.

    Do IIS reset.

    If the issue still exists, try to create a new search service application.

    Best Regards,

    Lisa Chen

    Thursday, October 30, 2014 10:14 AM
  • The account is ok.
    Thursday, October 30, 2014 12:34 PM
  • Please share the screenshot of your crawl history.

    Thank You, Pallav S. Srivastav ----- If this helped you resolve your issue, please mark it Answered.

    Thursday, October 30, 2014 12:40 PM
  • Hi,

    Please make sure the content access account of the search service application with read permission on web applications

    Please make sure Search Service Application connection properly.

    Open Central Admin > Application Management > Manage web applications > Select your applications > Select Service Connections from top ribbon > Make sure your Search service application is selected.

    Do IIS reset.

    If the issue still exists, try to create a new search service application.

    Best Regards,

    Lisa Chen

    Content Access Account has read permission on SharePoint Content DB which includes the site collection(s).

    Search Application Connection is ok.

    Thursday, October 30, 2014 12:56 PM
  • I remind about the error I'm getting in Crawl Log:

    "Crawler couldn't change information with the server. Check that the server is available and the firewall settings are well configured."

    I don't know what it is excactly in English because the system is in another language.

    Thursday, October 30, 2014 1:01 PM
  • Are Windows Firewall on your server disabled?

    Also, if you are using Host Header then, is the binding correctly configured in IIS and AAM.

    Try to make a host entry update on your APP server where search is configured and then try to perform index reset and full crawl.


    Thank You, Pallav S. Srivastav ----- If this helped you resolve your issue, please mark it Answered.

    Thursday, October 30, 2014 2:36 PM
  • I remind about the error I'm getting in Crawl Log:

    "Crawler couldn't change information with the server. Check that the server is available and the firewall settings are well configured."

    I don't know what it is excactly in English because the system is in another language.


    Can you browse to the WebApp from the server that is performing the Crawl? The issue is usually the most typical is the LoopBackCheck 

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
    3. Right-click MSV1_0, point to New, and then click Multi-String Value.
    4. Type BackConnectionHostNames, and then press ENTER.
    5. Right-click BackConnectionHostNames, and then click Modify.
    6. In the Value data box, type the host name or the host names for the sites that are on the local  computer, and then click OK.
    7. Quit Registry Editor, and then restart the IISAdmin service.



    Thanks and Regards Rahul Dagar

    Thursday, October 30, 2014 6:02 PM
  • Hi Freedomic:

    If you have tried everything and you still don't have your search working, delete the SSA and start over.

    Set up a proper service/system account to handle the search.

    Refer to the link:

    http://technet.microsoft.com/en-us/library/gg502597(v=office.15).aspx

    Best Regards,

    Lisa Chen

    Friday, October 31, 2014 6:10 AM
  • The Search has been working previously. There hasn't been any changes that could affect the search.

    I found the error message in English:

    The crawler could not communicate with the server. Check that the server is available and that the firewall access is configured correctly.

    There are topics when searching with Google this.

    The error comes from all 3 start addresses that are provided for the Content Source.


    • Edited by Freedomic Friday, October 31, 2014 7:24 AM
    Friday, October 31, 2014 7:24 AM
  • The Search has been working previously. There hasn't been any changes that could affect the search.

    I found the error message in English:

    The crawler could not communicate with the server. Check that the server is available and that the firewall access is configured correctly.

    The error comes from all 3 start addresses that are provided for the Content Source.

    Question
    Can you browse to the WebApp from the server that is performing the Crawl? The issue is usually the most typical is the LoopBackCheck 
    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
    3. Right-click MSV1_0, point to New, and then click Multi-String Value.
    4. Type BackConnectionHostNames, and then press ENTER.
    5. Right-click BackConnectionHostNames, and then click Modify.
    6. In the Value data box, type the host name or the host names for the sites that are on the local  computer, and then click OK.
    7. Quit Registry Editor, and then restart the IISAdmin service.


    Thanks and Regards Rahul Dagar

    Friday, October 31, 2014 7:25 AM
  • The Search has been working previously. There hasn't been any changes that could affect the search.

    I found the error message in English:

    The crawler could not communicate with the server. Check that the server is available and that the firewall access is configured correctly.

    The error comes from all 3 start addresses that are provided for the Content Source.

    Question
    Can you browse to the WebApp from the server that is performing the Crawl? The issue is usually the most typical is the LoopBackCheck 
    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
    3. Right-click MSV1_0, point to New, and then click Multi-String Value.
    4. Type BackConnectionHostNames, and then press ENTER.
    5. Right-click BackConnectionHostNames, and then click Modify.
    6. In the Value data box, type the host name or the host names for the sites that are on the local  computer, and then click OK.
    7. Quit Registry Editor, and then restart the IISAdmin service.


    Thanks and Regards Rahul Dagar

    This didn't help.

    Friday, November 7, 2014 12:04 PM
  • Are windows Firewall disabled on you SharePoint servers and SQL server?

    If yes, then follow below mentioned steps

    Go and edit host file on the server where search is configured. Provide IP address of the APP server and URL of the site we are trying to crawl

    Save the file and perform IISreset

    G to search service application

    Run Incremental crawl

    If error please provide crawl log error message.


    Thank You, Pallav S. Srivastav ----- If this helped you resolve your issue, please mark it Answered.

    Saturday, November 8, 2014 7:34 AM
  • Thanks for all the replies and suggestions!

    The problem is solved and it was about server Proxy settings which were preventing the crawler's connection to the content source (and its starting addresses).

    Finally there was also a new error type for sps3:// starting address for the person search. That was solved By adding search account as an administrator in User Profile Service.

    • Marked as answer by Freedomic Monday, November 17, 2014 12:31 PM
    Monday, November 17, 2014 12:31 PM