I can't find Console Application Template under Visual Studio 2017


  • I tried to use a Console application template under C# in New Projects but it seems Visual Studio kind of missing it .

    Can anyone of you help me in figuring out how to get that console application template.

    Thursday, March 16, 2017 5:26 AM

All replies

  • Hi,

    I notice that the issue is related to the Visual Studio application instead Visio product. To better resolve your issue, I would move the thread to Visual Studio development forum for more suggestion:

    Hope you can find the solution there. Have a nice day!


    Winnie Liang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Friday, March 17, 2017 2:08 AM
  • Hi akhil_dabral,

    Thanks for posting here.

    To create a Console Application in Visual Studio, you need to follow the steps.

    New->Project->Installed Templates->Visual C#-> Console App(.NET Framework)/ Console App(.NET Core)

    Please check it first. If you have already followed the above steps, then check whether the checkbox of ".net-Desktop development" on top right is selected or not on Visual Studio installer:

    If still no help, you could to restore the template in VS2017 then try it again.
    Please refer to the following steps:
    1. Delete the ItemTemplatesCache, ProjectTemplatesCache folder (C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE).
    2. In the command prompt, navigate to the location of devenv.exe. This file is located in <Visual Studio Installation Path>\Common7\IDE.
    3. Type "devenv /installvstemplates" and press Enter.

    Hope this can help you.

    MSDN Community Support

    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact

    Monday, March 20, 2017 8:32 AM