locked
SQL performance monitor error RRS feed

  • Question

  • I am runninng Alert monitor on SQL 2005 server and got this error:

    Windows cannot load extensible counter DLL MSSQLServerOLAPService, the first DWORD in data section is the Windows error code.

    Event ID 1023, source Perflib, Type: error

     

    Tried to follow MS article, but it did not fix a problem.

     

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp

    .

    http://support.microsoft.com/?kbid=912399

    Any ideas how to fix this error?

    Thank you

    Wednesday, August 30, 2006 4:51 PM

Answers

All replies

  • Below KB article fixed my problem... happy happy...

    Make sure there are 2 users "Network" and "Netowrk Service".

    http://support.microsoft.com/?kbid=912399

    Thanks,

     

    • Proposed as answer by DK123_msdn Monday, September 27, 2010 6:00 AM
    • Marked as answer by Kalman TothEditor Monday, October 4, 2010 5:51 PM
    Monday, March 5, 2007 7:10 PM
  • I had the same error trying to monitor some SQL performance counters on a Windows 2003 Server running SQL 2005. What I did was basically take the information from the support article and modified it a little.

     

    Instead of adding the Network Services account with read/execute on the dll, and with read on bin / bin\en, I added SERVER\Performance Log Users and SERVER\Performance Monitor Users with the same rights

     

    Worked like a charm after that - but then again - if you havent figured out how to do this since March Im guessing you no longer care :-)

     

    Wednesday, January 30, 2008 9:10 AM
  • I have SBS server 2003, i tried giving the permissions to network and network services on the whole folder, but its not solving the problem, the server is quite slow, and it keeps logging on the same error. 

    I was not able to find Server/Performance Log Users and Server/Performance Monitor Users, are they refered with a different name when you search for users, or services on the server.

    Thanks.....

    Tuesday, February 5, 2008 2:50 AM
  • Thank you. your suggestion works!


    I added 2 users "Network" and "Netowrk Service"

    give access to files and folders referred by http://support.microsoft.com/?kbid=912399


    and now , no error message appear in my event viewer.


    Thanks again

    -roxy -
    Monday, August 11, 2008 6:35 AM
  • Running SQL Server 2005 SP2 on an x64 machine I was getting the same error every 15 second. After applying suggestions here these were resolved but now there is a new error occurring every 5 minutes:

    Windows cannot load extensible counter DLL CcmFramework, the first DWORD in data section is the Windows error code.

    Searching for this error produced a couple of responses in a foreign language but nothing of use.

    Does anyone have any ideas regarding this counter or resolution.

    Thanks.

    Friday, December 19, 2008 4:13 AM
  • Hi

    This seems to a known issue. 

    Add a DWORD "Disable PerformanceCcounters" with a value of 1 by searching the performance key under registry HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\

    Refer http://support.microsoft.com/default.aspx?scid=kb;en-us;300956 for more information.

    Thanks
    Sreekar
    • Proposed as answer by ch_karthik Friday, December 26, 2008 12:58 PM
    • Marked as answer by Kalman TothEditor Monday, October 4, 2010 5:51 PM
    Friday, December 19, 2008 9:41 AM
  • Hi Sreekar

    Thanks for advice.

    I cannot apply this until early January as this is a production System and I cannot make changes to registry until next maintenance window.

    I will advise the result.

    Thanks

     

    Nadreck

    Friday, December 26, 2008 1:47 PM
  • Even though  SERVER\Performance Log Users and SERVER\Performance Monitor Users were having the correct permission on Msmdctr90.dll, it was not working for me.

    Solution provided at http://support.microsoft.com/?kbid=912399 worked for me.

    Thanks

    Monday, September 27, 2010 6:00 AM
  • Below KB article fixed my problem... happy happy...

    Make sure there are 2 users "Network" and "Netowrk Service".

    http://support.microsoft.com/?kbid=912399

    Thanks,

    This worked for me.

    Thanks,

    Thomas

    Monday, March 5, 2012 3:06 PM
  • Thank you for help!
    Wednesday, July 24, 2013 6:41 AM