none
Win 8 Dev Prev. VS11 Problems RRS feed

  • Question

  • I can't seem to get any of the EF versions onto my VS11 projects. The error is as follows. Could not install package 'EntityFramework 4.2.0.0'. You are trying to install this package into a project that targets '.NETCore,Version=v4.5', but the package does not contain any assembly references that are compatible with that framework. For more information, contact the package author. I saw a video on the build site and they were using EF to provide a data service to a WinRT client. --------------------------------------------------------------------------------
    Thanks, Terrence
    Wednesday, December 7, 2011 8:39 PM

All replies

  • Hi Terrence,

    Welcome!
    We will do some more pending research  about your problem and come back as soon as possible, Thanks for understanding.
    Have a nice day.


    Alan Chen[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, December 8, 2011 9:23 AM
    Moderator
  • I am able to install it from package manager / Nuget

    PM> install-package entityframework

    You are downloading EntityFramework from Microsoft, the license agreement to which is available at http://go.microsoft.com/fwlink/?LinkId=242868. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.

    Successfully installed 'EntityFramework 4.3.1'.

    Successfully added 'EntityFramework 4.3.1' to TestEF.

    Can you please try this using latest VS11 build ?

    Wednesday, May 9, 2012 9:12 PM
  • If you would like to take advantage of all the EF goodness that comes with .NET Framework 4.5 (enums, spatial types, TVFs etc) you need to install EF 5.0.0.0. Since this is a prerelease version you need to install it from package manager console using the following command:

    Install-Package EntityFramework -Pre

    I don't think EF can be used in WinRT app though.

    Thanks,

    Pawel

    Thursday, May 10, 2012 2:43 AM