locked
Error : DEP0700 : Registration of the app failed. Another user has already installed an unpackaged version of this app

    Question

  • Hi,

    I have some Windows 8 apps on the Store. One of them is "Steam Launcher". Today, I started a new version of the app, but got some problems.

    Three days ago, I updated my home server to a Windows 2012 Server, and joined the domain. Because of this, my "old" Microsoft account was pointless, so I deleted it and linked my domain account with my Microsoft account.

    Since then, when I try to deploy (debut) my own app, I'm unable to do so.

    I've tried to change the application name, it works, but as soon as I create app package, the Windows Store "resets" its name to the previous one.

    As the old account is now unavailable, I've tried a lot of things, like deleting C:\Program Files\WindowsApps\61530NinjaFactory.SteamLauncher_1.0.0.2_neutral__z57vrmdxje7nr\, or C:\ProgramData\Microsoft\Windows\AppRepository\61530NinjaFactory.SteamLauncher_1.0.0.2_neutral__z57vrmdxje7nr.xml, but this changes nothing.

    Could not either find any registry key related to the app.

    Get-AppxPackage gives me this:

    Name                   : 61530NinjaFactory.SteamLauncher
    Publisher              : CN=01075C53-DF63-425F-9C95-0A2F597B93FC
    Architecture           : Neutral
    ResourceId             :
    Version                : 1.0.0.2
    PackageFullName        : 61530NinjaFactory.SteamLauncher_1.0.0.2_neutral__z57vrmdxje7nr
    InstallLocation        : E:\Dev\Windows 8\Steam Launcher\Steam Launcher\bin\Debug\AppX
    IsFramework            : False
    PackageFamilyName      : 61530NinjaFactory.SteamLauncher_z57vrmdxje7nr
    PublisherId            : z57vrmdxje7nr
    PackageUserInformation : {S-1-5-21-3919835581-3854878348-3552985018-1001 [Unknown user]: Installed}

    I've tried deleting E:\Dev\Windows 8\Steam Launcher\Steam Launcher\bin\, but still no luck

    I'm a bit stuck here, as I can't change my package name, the old account is inaccessible (recreating it doesn't allow me to remove the app either),and don't want to reinstall my computer (and I won't)

    Any idea?

    Mikael.


    Friday, December 28, 2012 2:54 AM

Answers

  • Here's how I fixed it, without having to change the package ID:

    1. Take control of the folder c:\Program Files\WindowsApps - giving Administrator full access. Make sure TrustedInstaller also has Modify rights as well. You're also taking ownership. If you're unawares, this is done via the Properties on that folder.

    2. Go to Services and stop the Windows Installer service.

    3. Open C:\ProgramData\Microsoft\Windows\AppRepository\ and delete the PackageRepository.edb file.

    4. Start the Windows Installer service again.

    5. Launch Visual Studio as Administrator.

    6. Attempt to launch your app. It should work.


    Check out "Fu" for Facebook uploading in Win8! | Author, Hacking the PSP & Geek My Ride | President, The Auri Group, LLC, www.aurigroup.com | Blog: http://auri.me

    • Marked as answer by Mika56 Tuesday, January 15, 2013 2:56 PM
    Tuesday, January 15, 2013 2:36 PM
  • Wow, thanks a lot!

    I did what you told me, and it worked fine.
    Some details:

     - Windows Installer service was already "not running", so I didn't have to stop it.
     - I needed to take ownership and full control over both C:\Program Files\WindowsApps and C:\ProgramData\Microsoft\Windows\AppRepository

    Remember to relaunch Visual Studio in administrative mode the first time, and to run a project; this will register Windows API
    After that, you can use Visual Studio in user mode

    Mikael.

    • Marked as answer by Mika56 Tuesday, January 15, 2013 2:56 PM
    Tuesday, January 15, 2013 2:56 PM

All replies

  • Hi,

    Using Procmon, I found that get-appxpackage reads the file C:\ProgramData\Microsoft\Windows\AppRepository\PackageRepository.edb

    I was then able to copy it somewhere else using robocopy form analysis

    Using Windows Search Index Analyzer (that's the only software I could find), I could clearly see an entry for my app in the "Package" table

    However, this app doesn't allow me to modify the file, so I'm still stuck

    No one knows?

    Mikael.

    Saturday, December 29, 2012 2:08 PM
    • Proposed as answer by TK MAHATO Sunday, December 30, 2012 7:21 PM
    • Unproposed as answer by Mika56 Sunday, December 30, 2012 7:28 PM
    • Proposed as answer by TK MAHATO Monday, December 31, 2012 7:04 AM
    • Unproposed as answer by Mika56 Wednesday, January 2, 2013 2:09 AM
    Sunday, December 30, 2012 7:21 PM
  • Hi,

    This doesn't help me at all, I already know how publishing works, I already did it 11 times, my problem is on my computer, where I can't install my app again (via Visual Studio) because it is already registered with an other user, who has been deleted

    Mikael.

    Sunday, December 30, 2012 7:29 PM
  • Here's how I fixed it, without having to change the package ID:

    1. Take control of the folder c:\Program Files\WindowsApps - giving Administrator full access. Make sure TrustedInstaller also has Modify rights as well. You're also taking ownership. If you're unawares, this is done via the Properties on that folder.

    2. Go to Services and stop the Windows Installer service.

    3. Open C:\ProgramData\Microsoft\Windows\AppRepository\ and delete the PackageRepository.edb file.

    4. Start the Windows Installer service again.

    5. Launch Visual Studio as Administrator.

    6. Attempt to launch your app. It should work.


    Check out "Fu" for Facebook uploading in Win8! | Author, Hacking the PSP & Geek My Ride | President, The Auri Group, LLC, www.aurigroup.com | Blog: http://auri.me

    • Marked as answer by Mika56 Tuesday, January 15, 2013 2:56 PM
    Tuesday, January 15, 2013 2:36 PM
  • Hi,

    Interesting !
    I'll try this tonight, I already tried something like this, but but deleting PackageRepository.edb and then restarting Windows 8. It seemed to work, but, then, Visual Studio was unable to find Windows SDK...

    Regards,

    Mikael Peigney.


    • Edited by Mika56 Sunday, March 10, 2013 1:29 PM
    Tuesday, January 15, 2013 2:39 PM
  • Wow, thanks a lot!

    I did what you told me, and it worked fine.
    Some details:

     - Windows Installer service was already "not running", so I didn't have to stop it.
     - I needed to take ownership and full control over both C:\Program Files\WindowsApps and C:\ProgramData\Microsoft\Windows\AppRepository

    Remember to relaunch Visual Studio in administrative mode the first time, and to run a project; this will register Windows API
    After that, you can use Visual Studio in user mode

    Mikael.

    • Marked as answer by Mika56 Tuesday, January 15, 2013 2:56 PM
    Tuesday, January 15, 2013 2:56 PM
  • The expected way to get around this without destroying the database of all of your apps is to log in to the old account and remove the package. If that is not possible, then you should remove the old account by launching c:\windows\system32\systempropertiesadvanced.exe and clicking the user profile settings... and deleting the offending profile.
    Tuesday, January 29, 2013 4:09 AM
  • Hi,

    Problem was, the user had already been removed.

    Your systempropertiesadvanced.exe solution may work, but as my problem is now fixed, I can't really try it. Note that I have two "Account Unknown" in my users list

    Mika.

    Tuesday, January 29, 2013 11:12 AM
  • Is this a known issue that every body that developers has to do?  This seams like Visual Studio should handle this better!  How do people normally get around needed to update there apps with out having to do this? I am having same issue and having to do this. This worked great but still think its crazy that we have to do it...
    • Edited by NHehn Friday, April 19, 2013 2:21 PM
    Friday, April 19, 2013 1:52 PM
  • @TK MAHATO: In which universe is this going to help on this issue?

    • Edited by FWinkler Friday, July 12, 2013 11:23 AM needed to make clear whom this comment is for.
    Friday, July 12, 2013 11:23 AM
  • I was able to fix it by editing my "package.appxmanifest" file.

    Go to the "Packaging" tab and change the "Publisher" by clicking "Choose Certificate". It had another developer's name in that box. So I just created my own Temporary Certificate. And it worked!

    • Proposed as answer by Chris Leyva Tuesday, July 23, 2013 8:48 PM
    Tuesday, July 23, 2013 8:48 PM
  • ty, that did the trick. I can confrim that this works for 8.1 build 9431 as well
    • Edited by kbo4sho Wednesday, July 24, 2013 5:02 PM added more
    Wednesday, July 24, 2013 5:01 PM
  • Thanks, this worked for me.  It is sad that even Microsoft software doesn't work well in the setup that they recommend.  I run as a non-admin user, as they recommend, in Win8.  I still have so many issues due to Visual Studio running as non-admin (by default), and in this case the "App Certification" tool forcing itself to run as admin.. so it doesn't find the app that I installed in VS, I assume because they are running under different user accounts.

    After using the steps here, I still can't get everything working from a non-admin account, so I redid them and then used an actual admin account for everything... using "run as admin" for VS wasn't enough, had to do it from an admin account session/login.

    Just always running VS as admin doesn't fix all of the issues either, still get weird issues a lot when testing due to the "app running under a different user account than I'm logged in as" mess.

    Tuesday, June 24, 2014 5:17 AM