none
BizTalk 2013R2 Web Service Response is very Slow RRS feed

  • Question

  • Hi,

    I have a simple test using wcf-sql adapter select data and get response.

    I publish this orchestration as web service.

    I create a test window form project call web service.

    When I run this project in first time get response very slow.

    But when 2nd, 3rd...get response quickly.

    Then I close test project and rerun it get very slow response.

    Repeat this step(close test project and rerun it) sometime get very slow response, sometime get timeout.

    What wrong in my test?

    Does someone have encountered the same problem like this?

    Please help.

    Thanks,

    Joe

    Tuesday, June 16, 2015 3:48 AM

Answers

  • What wrong in my test? --> There is nothing wrong in your test. 

    Does someone have encountered the same problem like this? -> yes its a common issue. you need to add following settings in BizTalk Configuration file. 

    SecondsIdleBeforeShutdown="-1" SecondsEmptyBeforeShutdown="-1"

    MSDN Article for the details-Orchestration Engine Configuration

    Blog Post for the details-BizTalk Servers Slow First Hit

    Also Check this in depth blog post for 15 sec delay issue, you may not have it but worth checking for this.

    Hope this helps.


    Greetings,HTH
    Naushad Alam

    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer
    alamnaushad.wordpress.com

    • Marked as answer by Angie Xu Tuesday, June 23, 2015 2:29 AM
    Thursday, June 18, 2015 8:02 PM
    Moderator

All replies

  • Hi Joe,

    It may be because IIS process get recycled after certain interval of time and to load the resources into memory it may take some time .This is the reason first request always takes some time .

    I would suggest to do some changes in recycle process at IIS level . There are other biztalk settings which you can try .

    1) Create seperate host and host handler for WCF service invoke .

    2 ) Increased the Throttling Settings Internal message queue size to 1000 from 100 In new Application Host.

    3) Set the Maximum number of messaging engine threads per CPU to 40 (By default it is 20).

    4) Increase the number of concurrent thread in BTSNTsvc.exe.config

    <configuration>
      <system.net>
        <connectionManagement>
          <add address="www.contoso.com" maxconnection="20" />
          <add address="*" maxconnection="10" />
        </connectionManagement>
      </system.net>
    </configuration>

    5) set max and min workers thread in registry for specific host instance

    for reference to registry change 

    https://msdn.microsoft.com/en-us/library/ff629681.aspx

    I would recommend to test these changes along with IIS recycle process on testing machine to validate the change .

    Thanks
    Abhishek

    Tuesday, June 16, 2015 4:25 AM
  • What wrong in my test? --> There is nothing wrong in your test. 

    Does someone have encountered the same problem like this? -> yes its a common issue. you need to add following settings in BizTalk Configuration file. 

    SecondsIdleBeforeShutdown="-1" SecondsEmptyBeforeShutdown="-1"

    MSDN Article for the details-Orchestration Engine Configuration

    Blog Post for the details-BizTalk Servers Slow First Hit

    Also Check this in depth blog post for 15 sec delay issue, you may not have it but worth checking for this.

    Hope this helps.


    Greetings,HTH
    Naushad Alam

    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer
    alamnaushad.wordpress.com

    • Marked as answer by Angie Xu Tuesday, June 23, 2015 2:29 AM
    Thursday, June 18, 2015 8:02 PM
    Moderator