none
Profiler seems available in Visual Studio 2015 Update 3 Community Edition - but can't use it!

    Question

  • Hi,

    I tried to use the profiler in VS 2015 Update 3 Community Edition but got an error when I chose the Sampling method of Performance Wizard:

    I chose the the available project and I get '8536' is not a valid Process ID.

    However if I choose Instrumentation all goes well...

    Any ideas?

    Juan


    Juan Dent

    Friday, July 01, 2016 1:13 AM

Answers

  • Hi Juan,

    Do you install the update 3 singly? I mean that if you update your VS2015 from the update 2 to update 3, whether it worked well before?

    In addition, do you test it in other VS 2015 machine?

    If it worked well before, I suggest you repair the update 3 again.

    Or you could repair your VS from the control panel, and then re-open your VS as the admin, check it again.

    Best Regards,

    Jack

    Update:

    I set up a clean VS2015 community with update 3 Environment, and then create a simple WinForm app or the MFC app, I could profile it normally using the Sampling method.

    So please check that whether all projects have the same issue, if all projects have the same issue, I think we would think about the VS IDE. Repair or re-install it would be a better choice. But if just the specific app has this issue, we would think about the project itself like the project type or others.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Monday, July 04, 2016 12:01 PM
    Moderator

All replies

  • Hi Juan Dent,

    thanks for posting here.

    This forum is about c++ development. Since your case is more related to vs diagnose setting. I will move your case to vs general forum for better support.

    Your understanding and cooperation will be grateful.

    Best Regards,

    Sera Yu


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Friday, July 01, 2016 2:52 AM
  • Hi Juan,

    Do you install the update 3 singly? I mean that if you update your VS2015 from the update 2 to update 3, whether it worked well before?

    In addition, do you test it in other VS 2015 machine?

    If it worked well before, I suggest you repair the update 3 again.

    Or you could repair your VS from the control panel, and then re-open your VS as the admin, check it again.

    Best Regards,

    Jack

    Update:

    I set up a clean VS2015 community with update 3 Environment, and then create a simple WinForm app or the MFC app, I could profile it normally using the Sampling method.

    So please check that whether all projects have the same issue, if all projects have the same issue, I think we would think about the VS IDE. Repair or re-install it would be a better choice. But if just the specific app has this issue, we would think about the project itself like the project type or others.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Monday, July 04, 2016 12:01 PM
    Moderator