Task "semi" completed, now locked by a running workflow


  • I have an approval workflow that is attached to a form library which has been working well for months.  We suddenly have a workflow task that seems to be in limbo - the Status shows "Complete", however the % Complete shows "0%" and the Outcome is blank.  The user believes that they did complete the approval task, and they obviously did something because the Status has been updated, but it almost seems like there was a glitch somewhere during the task update and the % Complete and Outcome didn't get updated.  Anyway, I'm must less concerned about figuring out what happened to the task (since it hasn't happened before and we've successfully completed the workflow on a form since) as I am in getting the task completed so that the workflow can complete.

    In the workflow history for the document the Tasks section shows the task as Completed but the Outcome is blank.  In the Workflow History section the details show that the Task was created but nothing since.  I have had the user try to update the task again but they receive the message "This task is currently locked by a running workflow and cannot be edited."  I have tried to restore the original version (1.0) of the task but receive the same error (the task's Version History shows a version 2.0 with a modified date/time but no other detail).  I have tried to change the Status back to In Progress by editing the workflow task list in datasheet view but my changes cannot be saved.

    Can anyone give me a pointer on how to "unlock" this task so that it can be completed?

    Tuesday, March 10, 2009 2:02 AM

All replies

  • Hi Chanda,


    If the approval workflow is built with Visual Studio, the error should be happened if specifying a fixed GUID as the task ID.


    If this is the cause of your issue, please change the task ID from fixed GUID to dynamic GUID.


    If this is not the cause of your issue, please let me know more information in order to do further research.

    1.    The type of your workflow(OOB workflow, SharePoint Designer workflow, Visual Studio workflow)

    2.    Related ULS logs located in %ProgramFiles%\Common Files\Microsoft Shared\web server extensions\12\LOGS.


    Let me know the result if possible.


    Lambert Qin | Microsoft Online Support Engineer
    How to ask a question in the forum (
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, March 13, 2009 9:10 AM
  • Lambert,

    Thanks for the reply, but please note that I'm not trying to troubleshoot the issue as it has only happened one time and since we have had successful tasks, I'm just asking how to "unlock" this one incomplete task.


    Friday, March 13, 2009 2:51 PM
  • Hi Chanda, I have this locked task issue too and I'm still trying to find a solution or workaround for it.

    But I also want to know how to "unlock" the task too since it's really unacceptable to terminate the task, then ask the submitter to submit the form (to create tasks) again and also ask the reviewers to provide their responses again.
    Friday, March 13, 2009 3:09 PM