none
WDK 8.1 seems to be missing parts RRS feed

  • Question

  • I have installed VS2013 sp1, SDK 8.0 then SDK8.1 and then WDK 8.1.  When I create a driver project with some driver code (just the .c and .h files) and try to compile it I get an error "missing tracewpp.exe".  This is in "windowskits\8.0\bin" but not in "windowskits\8.1\bin".  In fact, the 8.0 directory has 112 items, the 8.1 has 24.  It appears that the 8.1 WDK is missing parts.  Should I install VS2012 with 8.0 for driver development or is vs2013 with 8.1 ready?  I was hoping to be current but if I am jumping the gun on this I will step back.

    Friday, March 14, 2014 12:08 PM

All replies

  • something is wrong with your install, 8.1 wdk RTM'ed this past summer and is fully functional

    d -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, March 14, 2014 4:12 PM
  • I have worked with another engineer here.  He got a proper install.  I had installed the current .net after I installed vs2013, but he had not.  I believe that if you have installed that separately then WDK does not install correctly.  I copied his windowskit\8.1 directory and it appears to be working now.
    Friday, March 14, 2014 4:24 PM
  • There is more to the WDK install outside of the windows kits\8.1 directory. There are MSBuild integration files under the MSBuild root for instance.

    d -- This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, March 14, 2014 8:26 PM