none
COM object not registered RRS feed

  • Question

  • I am building a custom WiX bootstrapper which first installs a third party application and then uses a COM object it registers to configure it. However it consistently returns this error in the installer log file:

    Retrieving the COM class factory for component with CLSID {7B250F68-BA8C-4353-BC72-8D41A0D4C2C0} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

    From Googling I have tried having the bundle register the COM object using regsvr32.exe. I have also tried to build the bundle for x86 (I also tried every other combination of x86, x64 and Any CPU that I could think of). Finally I tried removing the interop DLL (it was x64) and adding it as x86.

    But nothing has cleared the error. :(

    Apologies if this is in the wrong forum.

    Friday, January 27, 2017 3:54 PM

All replies

  • 1 are you sure the com object is registered correctly? if you cannot find the COM object's entry in expected locations using regedit go to the WiX-users mailing list for help. Why you use regsvr32 and not WIX in a WIX installer to register a COM object by the way? 

    2 you should only ship an interop dll that has the same bitness with your COM object. Otherwise you cannot load both in the same process and that defeats the purpose of having an interop dll.

    This doesn't really have anything to do with CLR.



    Visual C++ MVP

    Friday, January 27, 2017 4:30 PM