none
Publish database (to a new "basic" scale db) from VS2013 times out RRS feed

  • Question

  • I'm trying to publish a database to a newly created server and database (using the new "basic" tier scale) from Visual Studio 2013. (This has been working fine to a legacy "web" scale database on a different server). I've created the new server and database from within the Azure Portal.

    After about four minutes, the Data Tools Operations window within Visual Studio fails during "Creating publish preview" with the message "Failed to import target model <database name>. Details message Unable to reconnect to database: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding."

    I've tried deploying the dacpac direct from SQL Server Management Studio, but I get a similar timeout message.

    I'm connecting with the main administrator user account created during database creation. I can create tables manually using SSMS as expected.

    Any ideas?

    Thursday, May 8, 2014 2:24 PM

Answers

  • Hello Stephen

    In order to change the command timeouts used in Visual Studio 2013 you will need to change the following registry setting:

    HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\12.0\SQLDB\Database\QueryTimeoutSeconds

    You can increase it to 300 (5 min) to see if that helps. You can also set it to 0 (infinite) so it won't time out on the client.

    For SSMS and the command line tools, the registry setting is:

    HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\SQLDB\Database\QueryTimeoutSeconds

    Lonny

    • Marked as answer by stephen_s_01 Thursday, May 8, 2014 5:26 PM
    Thursday, May 8, 2014 5:04 PM

All replies

  • Hi Stephen,

    The new SQL Database service tiers, including Basic, have resource governance in place in order to provide predictable performance. While the deployment may take more time on Basic than Web it should not fail, can you please contact me on tobias dotternstrom at microsoft dot com so we can take a look at what is going on here? It is also important to note that we are still in preview and are listening closely to customer feedback, this includes tuning of the performance levels.


    Thank you!

    /Tobias

    Thursday, May 8, 2014 4:08 PM
  • Thanks for your reply Tobias.

    I've tried emailing you (tobias [dot] ternstrom [at] microsoft [dot] com) but get a bounced message with recipient not found.

    Thursday, May 8, 2014 4:37 PM
  • Hello Stephen

    In order to change the command timeouts used in Visual Studio 2013 you will need to change the following registry setting:

    HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\12.0\SQLDB\Database\QueryTimeoutSeconds

    You can increase it to 300 (5 min) to see if that helps. You can also set it to 0 (infinite) so it won't time out on the client.

    For SSMS and the command line tools, the registry setting is:

    HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\SQLDB\Database\QueryTimeoutSeconds

    Lonny

    • Marked as answer by stephen_s_01 Thursday, May 8, 2014 5:26 PM
    Thursday, May 8, 2014 5:04 PM
  • That did it - thanks Lonny.

    Nine minutes. I know it's only the "basic" scale, but first impressions of performance are concerning. I wasn't expecting to have to disable the timeout to get a fairly simple test schema deployed.

    The features for the new service levels look awesome - I really hope the performance can get to where it needs to be.

    Cheers.

    Thursday, May 8, 2014 5:26 PM
  • I am sorry about the e-mail problem, please try tobiast at microsoft dot com.

    Thanks!

    /Tobias

    Thursday, May 8, 2014 5:52 PM