locked
IIS 7.0 Vista Business / Top Level ASP Pages working. Subdirectories not working RRS feed

  • Question

  • User-1591171179 posted

    I have moved a  website onto a Vista Business box and the here is the error message I get when trying to browse into a subdirectory.

    An error occurred on the server when processing the URL. Please contact the system administrator

    I have turned off Show Friendly HTTP Errors

    In the IIS Management Console I have also done the following:
    Verified that the ASP Handler Module is there.
    Enable Parent Paths = True (so that my ../../include will work)

    Enabled the IUSR Account with Full Control over all Subdirectories.

    What am I doing wrong?

    What needs to be configured to get this up and running?

    Subdirectory pages that are just HTML work, but any pages even one with a <%= Now() %> returns the above error message.
    I would think that the ASP.DLL is not functioning on that directory.

    Wednesday, May 2, 2007 2:36 PM

Answers

  • User-1591171179 posted

    Hi and thanks for your response.

     I have figured this problem out.  Here is the fix that worked for me.

     I had tried to set Enable Parent Directory to TRUE on the Virtual Directory that I had created, this was the right thing to do.  But you also need to set it to TRUE on the Default Web Site.  Once I set the Default Web Site to TRUE all of my ../../includes worked.

     Thanks for your responses.

    Jason

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, May 4, 2007 5:47 PM

All replies

  • User-1591171179 posted

    I just created a new folder on my webserver.  devjason.

    In this folder I created a file called default.asp.

    Default.asp works fine with a simple now() and response.write "This is a file in the root folder<br>"

    I also created a subfolder called subfolder with a default.asp file in it.

    This file also works fine.

    In the root folder I created another subfolder called includes.

    I placed a file called dbconn.asp in it.  With just response.write "File Included<br>".

    I then copied this file into subfolder as well.

    In subfolder default.asp I created an include file to dbconn.asp.  The file worked fine.. File included was displayed.

    I now modified default.asp to Include file <!--#include file="../includes/dbconn.asp" -->

    Now I get the nasty error message of "An error occurred on the server when processing the URL. Please contact the system administrator"

    Wednesday, May 2, 2007 4:23 PM
  • User-848894299 posted

    Jason, let me just make sure I understand your scenario correctly. Here is the layout of the files that you described, please correct me if this is not what you described:

    /myappl/default.asp                                  c:\myappl\default.asp
    /myappl/subfolder/default.asp                    c:\myappl\subfolder\default.asp
    /myappl/subfolder/dbconn.asp                   c:\myappl\subfolder\dbconn.asp

    /myappl/includes/dbconn.asp                    c:\myappl\includes\dbconn.asp

    Questions:

    1)

    /myappl/subfolder/default.asp
    you mentioned this default.asp include dbconn.asp, and it worked fine.
    I assuem this include the dbconn.asp (from c:\myappl\subfolder\dbconn.asp) in your c:\myappl\subfolder\default.asp ASP file, right?

    2)

    The problem that you have is that when you modify the default.asp (c:\myappl\subfolder\default.asp) to include another dbconn.asp (from c:\myappl\includes\dbconn.asp), you get this error message right?

    Other than the above things that I want to confirm, could you also enable the AspScriptErrorSentToBrowser property, so that we can see the actual error message. You can do this follow the instructions in here.

     Ray

    Thursday, May 3, 2007 4:15 PM
  • User-1591171179 posted

    Hi and thanks for your response.

     I have figured this problem out.  Here is the fix that worked for me.

     I had tried to set Enable Parent Directory to TRUE on the Virtual Directory that I had created, this was the right thing to do.  But you also need to set it to TRUE on the Default Web Site.  Once I set the Default Web Site to TRUE all of my ../../includes worked.

     Thanks for your responses.

    Jason

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, May 4, 2007 5:47 PM
  • User1073881637 posted
    We appreciate you posting the solution.  This will definitely help a lot of other people when they try to migrate classic asp apps to IIS7 / LH and / or Vista.
    Saturday, May 5, 2007 2:41 AM
  • User1196681416 posted

    I had the same problem and parent directories did not fix.. however going in to the - asp settings > debugging properties > send erros to browser = true   - made my life ohhh  so simple!!!! Now it tells you exaxtly what is wrong!

    Thursday, February 7, 2008 5:08 PM