locked
Session state for Reportviewer fails with AppFabric cache RRS feed

  • Question

  • Hi there,

    We are trying to use session state caching for reportviewer on Azure web application. We have set an AppFabric cache and followed instructions as per http://msdn.microsoft.com/en-us/library/gg278339.aspx.

    We are gettting the following error:

    Server Error in '/' Application.

    It has been reported already athttp://social.msdn.microsoft.com/Forums/en-AU/appfabricctp/thread/6ffe2f0a-c482-4514-9cf1-14685f0ecd3a

     

    Does anyone knows if it has been solved? what can I do to fix it?

     

    Thanks in advance. 

    Type 'Microsoft.Reporting.WebForms.SyncList`1[[System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]' is an invalid collection type since it does not have a default constructor


    Dánfer Habed López
    Thursday, November 3, 2011 4:41 PM

Answers

  • Hi,

    Sorry for the inconvenience, unfortunately I don’t think we can do anything at this moment. We have to wait for a future version of ReportViewer that provides a default constructor SyncList~1.

     

    Best Regards,

    Ming Xu.


    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    Friday, November 4, 2011 10:29 AM

All replies

  • Hi,

    Sorry for the inconvenience, unfortunately I don’t think we can do anything at this moment. We have to wait for a future version of ReportViewer that provides a default constructor SyncList~1.

     

    Best Regards,

    Ming Xu.


    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    Friday, November 4, 2011 10:29 AM
  • I've published an article that mentions this and discusses workarounds:  "Using the ReportViewer ASP.NET Control in Windows Azure", http://msdn.microsoft.com/en-us/library/hh825825(VS.103).aspx

    Saturday, February 11, 2012 12:04 AM
  • Hi Tim,

    Just read your detailed article and attempted to download the hotfix - but it doesn't seem to be available anymore.

    The Reportviewer in local processing mode has to have session state, so just wondering if you knew why the hotfix is no longer available? or maybe had any other news or updates?

    Has anyone been able to deploy multiple instances on Azure using the ReportViewer in local processing mode, without getting the 'session expired, cant be found error'?

    Kind Regards

    Mike


    Saturday, April 28, 2012 10:26 AM