none
unable to find a version of the runtime to run this application RRS feed

  • Question

  • I have an application written using Visual studio 2005 (in VB.Net). When I run it on any machine I get "unable to find a version of the runtime to run this application” and this same application successfully some other PCs

     

    And these following processes I have already done:

    1. Repair and reinstall .net framework2.0
    2. I also rebuild my application setup.
    3. Scan my PC with antivirus and install new updated antivirus
    4. I have format my pc and reinstall dotnet framwork2.0 and my project.
    5. And also download .net framework cleanup tool install it.

     

     

    So if any one has solution excluding the above then plz give me as soon as possible.

     

    https://mail.google.com/mail/?ui=2&ik=e858acf7c1&view=att&th=12a6629f2204128e&attid=0.1&disp=inline&realattid=f_gcrk1gea&zw

     

     

    Friday, August 27, 2010 5:20 AM

All replies

  • Hi parames,

    Welcome to MSDN forum.

    Could you please check what is the different with the issue machine and other PCs?

    Could you please check whether .NET Framework 2.0 is installed correctly on your machine or not?

     

    You could download the Verification Tool from the following link.

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

     

    Best Regards

    Larcolais Gong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, August 30, 2010 7:24 AM
  • Hi parames,

    I'm writing to follow-up this post.

    Any update?

    Best Regards

    Larcolais Gong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Friday, September 3, 2010 4:51 AM
  • it does not work as i had verified it msg cam "product verification succeeded

    then too wen i run my application the same error occur

    Sunday, October 24, 2010 5:32 AM
  • I also faced the same error and then followed the same steps as given above

    However it didn't resolve the issue

    Then i decided that just formatting the C drive is not enough

    Hence i took a back up of all my Remaining drives on an external hard disk

    You can also take a backup in your drive depending on the data you have.

    Like i mentioned,i had tried all the steps given above

    i realised that formatting the C drive is not enough, after i inserted the Windows XP Cd Rom,

    the first thing i did was to delete all the partitions,as a result all data would be lost thereby ruling out

    any malware infection.The reason i deleted all partitions is because if the virus or malware would be present  in D or E drive,it will likely infect the newly formatted C drive.

    Hence i deleted all the partitions resulting in all data lost ,then i created 3 new partitions and then formatted C Drive

    Then i loaded the application and it worked

    Eureka

    Regards

    Aravind Shenoy

    Tuesday, March 22, 2011 11:01 AM