Need help with locating resources within UITypeEditors RRS feed

  • Question


    I'm building a form to help support a custom windows workflow Activity at design time.
    My setup looks like so..

    WF Class Library -> UITypeEditor -> Windows Form ->
                        ------------------ Seperate Class Library ---------------------

    Within the UITypeEditor, I attempt to load an EDM entity to pass along to the form.
    This fails with .

      The specified named connection is either not found in the configuration, not intended to be used with the EntityClient provider, or not valid

    The connection info is fine, the real problem is that the app.config file can't be loaded properly when EDM initializes.
    When launched from a seperate Windows app , everything works so it seems to me that the failure
    to locate the resource pertains to the host type, in this case Visual Studio.

    I tried using WPF in a previous approach with the same core problem. The controls xaml could not be located. I've tried copying
    the app config file everywhere looking for a hit. Also, tweeked Copy Local on the app.config as well. No luck. Urrrggg!!!!!

    Any ideas on how to approach this?

    • Moved by Rong-Chun Zhang Monday, October 20, 2008 6:44 AM related to WF designer (Moved from Visual Studio Extensibility to Where is the Forum For…?)
    Tuesday, October 14, 2008 3:29 PM