locked
EVRPresenter Regsvr32 RRS feed

  • Question

  • Hi all,

      I'm trying to run the EVRPresenter sample. But, when I try to register the EVRPresenter.dll, something goes wrong and the application stops.

    I'm working with VC++ 2008 Express Edition
    and Windows 7 - with the SDK for Windows 7 and .NET Framework 3.5

     After built the sample, I get the window pop up to enter the executable file (regsvr32) name and the URL where the project can be accessed.

    I've been tried the following options, but any of them have been worked :(

    1) executable file name: regsvr32 EVRPResenter.dll
        URL (ATL server only): empty

      Result: Error:
      regsvr32 EvrPresenter.dll was not found. Do you want to select a different file?
      You may need to enter the full path.

    2)  executable file name: regsvr32 C:\nb\MF\EVRPresenter\Debug\EVRPresenter.dll
        URL (ATL server only): empty

    Result: Same than option 1.

    3) executable file name: C:\Windows\system32\regsvr32.exe C:\nb\MF\EVRPresenter\Debug\EVRPresenter.dll
        URL (ATL server only): empty

    Result: Same than option 1.

    4) executable file name: C:\Windows\system32\regsvr32.exe
        URL (ATL server only): C:\nb\MF\EVRPresenter\Debug\EVRPresenter.dll

    Result: No debugging information:
      Debugging information for 'regsvr32.exe' cannot be found or does not match. Symbols not loaded.
      Do you want to continue debbugging? Yes|No
      Yes: RegSvr32:
        To register a module, you must provide a binary name.
        Usage: regsvr32 [/u] [/s] [/n] [/i[:cmdline]] dllname


    >>> How it would be the right way to introduce these values?? if anyone knows how to resolve it, please let me know.


    Thanks in advance.
    -Enby

    Saturday, April 25, 2009 4:00 PM

Answers

  • But you still might need to run the command line with elevated privileges. (From the start menu, Run As Administrator.)

    - Mike
    Mike Wasson (SDK Documentation)
    Monday, April 27, 2009 4:58 PM

All replies

  • Have you tried registering it from the command line?

    Open a command prompt as administrator

    Navigate to the EVRPresenter sample directory

    regsvr32 Debug\evrpresenter.dll



    - Mike
    Mike Wasson (SDK Documentation)
    Saturday, April 25, 2009 11:13 PM

  • Hi Mike,

     Thanks for your reply, I did it and I get the error 0x80070005. The entire message is as follows:

       RegSvr32:
         The module "Debug\EVRPresenter.dll" was loaded but the call to DllRegisterServer failed with error code 0x80070005.
          For more information about this problem, search online using the error code as a search them.

      >> do you know what this error means? Meanwhile I'll search online for a solution.

    Thanks.
    -Enby.
    Sunday, April 26, 2009 1:02 AM
  • Did you run the comand prompt as administrator?

    - Mike
    Mike Wasson (SDK Documentation)
    Sunday, April 26, 2009 11:22 PM

  • Yes Mike,  actually is the only account that I have on this lap.
    I already changed the "Everyones" profile in the regedit (HKEY_CLASSES_ROOT and HKEY_LOCAL_MACHINE)  to full access, but it doesn't work either.

    - Enby.
    Monday, April 27, 2009 12:43 AM
  • But you still might need to run the command line with elevated privileges. (From the start menu, Run As Administrator.)

    - Mike
    Mike Wasson (SDK Documentation)
    Monday, April 27, 2009 4:58 PM

  • I ran it as a Administrator (run box: cmd,  instead of hitting the enter I used Ctrl+Shift+Enter to open it as Administrator).
    I got the same result, still the error is appearing. 

    -Enby
    Monday, April 27, 2009 5:41 PM

  • Mike,
      I finally registered. I opened the cmd as administrator using the following steps:
        * click start->all proograms->accessories and then right-click on the command prompt and click run as administrator.


    Thanks for your help :D
    -Enby.
      
    Monday, April 27, 2009 5:48 PM

  • So, now I did the six steps that appear on the EVRPResenter sample link:
      - Open a file (s1.wmv)
     - select "Custom EVR Presenter" ({9707FC9C-807B-41E3-98A8-75176F95A062})

    and I got the following error:
      Playback Error (HRESULT = 0xC00D36FA)

    Is this regarding also to the EVRPresenter.dll ?
    When I registered the dll I got the message: "DllRegisterServer in Debug\EVRPresenter.dll succeeded."

    -Enby
    Monday, April 27, 2009 6:03 PM

  • I found that this error is regarding to the Media Sink.

    Error:   0xC00D36FA
    Description:   Activate failed to create mediasink. Call OutputNode::GetUINT32(MF_TOPONODE_MAJORTYPE) for more information.
      #define: MF_E_CANNOT_CREATE_SINK

    But when I use the MFPlayer without check the Custom EVR Presenter box, the player works without any problem.

    Any ideas??

    -Enby.
    Wednesday, April 29, 2009 5:22 PM