none
Biztalk 2010 and SAP SNC RRS feed

  • Question

  • Hi,

    Im trying to send to SAP using the WCF-SAP adaptor using SCN to get SSO working.  I am however getting the below error when trying to send.  Has anyone seen this before?

    Error Description: Microsoft.ServiceModel.Channels.Common.ConnectionException: Details: ErrorCode=RFC_OK. ErrorGroup=RFC_ERROR_COMMUNICATION. SapErrorMessage=SAP_CMINIT3 : rc=20 > Connect to SAP gateway failed Connect_PM  GWHOST=xysapdev, GWSERV=sapgw00, SYSNR=00

    LOCATION    CPIC (TCP/IP) on local host with Unicode

    ERROR       SncPDLInit()==SNCERR_INIT

                Unable to load GSS-API DLL

                named "C:\Windows\System32\gx64krb5.dll"

    TIME        Tue Jun 19 12:36:52 201

    RELEASE     710

    COMPONENT   SNC (Secure Network Communication)

    VERSION     5

    RC          -1

    MODULE      sncxxdl.c

    LINE        378

    DETAIL      LoadLibrary("C:\Windows\System32\gx64krb5.d.  AdapterErrorMessage=. ---> Microsoft.Adapters.SAP.RFCException: Details: ErrorCode=RFC_OK. ErrorGroup=RFC_ERROR_COMMUNICATION. SapErrorMessage=SAP_CMINIT3 : rc=20 > Connect to SAP gateway failed

    Connect_PM  GWHOST=xysapdev, GWSERV=sapgw00, SYSNR=00

    LOCATION    CPIC (TCP/IP) on local host with Unicode

    ERROR       SncPDLInit()==SNCERR_INIT

                Unable to load GSS-API DLL

                named "C:\Windows\System32\gx64krb5.dll"

    TIME        Tue Jun 19 12:36:52 201

    RELEASE     710

    COMPONENT   SNC (Secure Network Communication)

    VERSION     5

    RC          -1

    MODULE      sncxxdl.c

    LINE        378

    DETAIL      LoadLibrary("C:\Windows\System32\gx64krb5.d.  AdapterErrorMessage=.

       at Microsoft.Adapters.SAP.RfcClientConnection.Open()

       at Microsoft.Adapters.SAP.SAPConnection.Open(TimeSpan timeout)

    Many thanks in advance


    GilesB

    Tuesday, June 19, 2012 11:40 AM

All replies

  • Hi,

    I'd suggest you restart the server to see if it helps.

    Friday, June 22, 2012 8:08 AM
  • Hi, that didn't make any difference. Thanks

    GilesB

    Tuesday, June 26, 2012 2:25 PM
  • (a) You could try increasing the OpenTimeout and SendTimeout binding properties.

    (b) Run the SAP Adapter Ports in their own host, and then configure BizTalk settings to limit the number of messages being processed by the port at any instant of time (the maximum number of messages the adapter can process simultanesously is equal to the MaxConnectionsPerSystem binding property). You could try reducing the "In-Process Messages Per CPU" value for example. More information here - http://msdn.microsoft.com/en-us/library/cc296779.aspx.

    (c) Set the EnableBiztalkCompatibilityMode binding property to true.

    (d) Increase the MaxConnectionsPerSystem binding property. Refer to the documentation if you want to set this value to a number greater than 100.

    http://social.msdn.microsoft.com/forums/en-US/biztalkr2adapters/thread/f220f0f3-7b37-4a0e-ba04-c24631074f61/


    Thanks, Raja MCTS BizTalk Server 2010, MCC If this answers your question please mark it accordingly

    Monday, July 2, 2012 8:51 AM
  • Hi Raja,

    We can connect to SAP however not using SNC.  Thanks anyway.


    GilesB

    Tuesday, July 3, 2012 10:45 AM