locked
Automatically configure network card (from Work to The Internet) RRS feed

  • Question

  • In the "Configure Network Adapters" screen in Wm 6 and 5 as well as PPC 2003 you can manually set "My network card connects to:" The Internet or Work.  I'm looking for a way to do this automatically.  I need the device's NIC to connect to the "Internet" by default.  I'd like to set this setting in .Net code using the ConfigurationManager.ProcessConfiguration but if it can only be done through CPF files then this would be good to know.  I do not wish to change the adapters just change the default config that the network card connects to.
    What XML do I need?  I'd be interested to hear any way this could be done.  Can anyone help me?

    So Far...

           const string networkInternetDefault="<wap-provisioningdoc>" + 
             "  <characteristic type=\"CM_Networks\">" + 
             "   <characteristic type=\"The Internet\">" + 
             "     <parm name=\"DestId\" " + 
             "     value=\"{436EF144-B4FB-4863-A041-8F905A62C572}\" />" + 
             "   </characteristic>" + 
             "  </characteristic>" + 
             "  <characteristic type=\"CM_NetEntries\">" + 
             "   <characteristic type=\"The Internet\">" + 
             "     <parm name=\"DestId\" " + 
             "     value=\"{436EF144-B4FB-4863-A041-8F905A62C572}\" />" + 
             "     <parm name=\"Adapter\" " + 
             "     value=\"PCCARD\\PHOTON1\" />" + 
             "   </characteristic>" + 
             "  </characteristic>" + 
             "</wap-provisioningdoc>" ;
          XmlDocument configDoc = new XmlDocument();
          configDoc.LoadXml(networkInternetDefault);
          ConfigurationManager.ProcessConfiguration(configDoc, false);
    
    
    Wednesday, April 6, 2011 12:41 PM

All replies

  • what's your connect to Internet way, through WIFI,GPRS or others. I don't think you configure the network adapters so that you can vistor the Internet.
    NEU_ShieldEdge
    Friday, April 8, 2011 5:56 AM
  • If you press START\SETTINGS\ then select CONNECTIONS tab then tap the Wi-Fi Icon, this shows the Configure Network Adapters screen.  I want to change the default value.  Initially this is The Internet but it has been changed on several thousand devices to Work and this needs to be changed.  This has been on the forums before (http://social.msdn.microsoft.com/forums/en-us/windowsmobiledev/thread/EA0E12EF-776B-47CD-9ED9-650D39AA1F53 about 4 years ago) but the relevant links to other forums have expired.

    Friday, April 8, 2011 10:32 AM
  • i have tested your codes, and i found the setting by these codes in Registry. What setting did you want to change? 
    NEU_ShieldEdge
    Thursday, April 14, 2011 10:51 AM
  • Sorry for the delay in replying I was on holiday.

    For WM5 and WM6 devices we have set:

    [HKEY_LOCAL_MACHINE\Comm\ConnMgr\Destinations\Work]
    "Secure"=dword:00000000
    "DestId"="{A1182988-0D73-439E-87AD-2A5B369F808B}"

    [HKEY_LOCAL_MACHINE\ControlPanel\WiFi\Ethernet]
    "DestId"="{436EF144-B4FB-4863-A041-8F905A62C572}"

    For PPC2003 we have set:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ConnMgr\Destinations\Work]
    "Secure"=dword:00000000
    "DestId"="{A1182988-0D73-439E-87AD-2A5B369F808B}"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ConnMgr\Providers\{f792e23c-dc19-4668-9be4-f8688b4c18d6}\CurrentWirelessNetwork]
    "DestId"="{ADB0B001-10B5-3F39-27C6-9742E785FCD4}"

    On the WM6 and WM5 devices we regularly see that while this value is set in the registry and the the default correctly displayed on the settings screen, it is only when you go into the setting screen that something changes within the crypto security hex keys and the actual change happens.  Until you go into the settings screen although the registry values are set, connection manger still uses the previous value.  This happens about fifty percent of the time, the other half it works.

    I want to achieve one hundred percent success in changing the setting from WORK to THE INTERNET as the default.

    Wednesday, April 20, 2011 7:38 AM
  • Hi tgderekw,

     

    I have the same problem. I have looking for this question in many forums , but answers are deleted.

    I've an Intermec 700 . I put on the cradle and a ballon message apperas with "the network card connect....". I need set "WORK" by default.

    Can you help me? Have you found a solution for this one?

     

    Monday, February 6, 2012 2:31 PM