none
Clickonce cause Visual Studio hangs on Windows 10

    Question

  • Hi, 
    Visual Studio 2015 on Windows 10 Enterprise hangs frequently when the project is using Clickonce technology.

    There is no apparent causes for the hangs, because the hangs occurs even when Visual Sudio is simply opened, but I'm not working with it.
    Other times, the hangs can occurs when I'm digiting on the editor.

    When an hangs occurs, simply the visual studio process is not responding and I must kill it and restart.

    Often, otherwise, the hangs occurs when launch the debugger: in that cases, the IDE is responsive, bug the builds is still on starting build. If I try to do anything, VS ask if I want to stop the debugger, but, if I click yes, the debugger does not stops.
    Even in that cases, I must kill Visual Studio.

    I'm using Visual Studio 2015 Enterprise, but the same problems occurs with other versions (VS 2010, VS 2012, VS 2012).

    My collegues have same problems with same configuration:

    • Visual Studio,
    • Windows 10,
    • projects with Clickonce

    With Windwos 8 or previous no problems occurs.

    Had anyone same problems?

    Thanks, 
    Francesco


    • Edited by franx_dj Tuesday, March 8, 2016 7:36 AM
    Tuesday, March 8, 2016 7:29 AM

Answers

  • Hi Francesco,

    Just create a simple WinForm app, for example, just add a button to the UI, and then publish using the default options, does it still crash the VS?

    I just test it in my windows 10 machine, it works normally in my side.

    Like the above steps, if all WinForm apps have the same issue, I think we would think about the VS or the windows Environment. 

    (1) Reset your VS settings, and then create a new project, create the setup project again.

    (2) Please disable the VS hosting process in the project property.

    >>I'm using Visual Studio 2015 Enterprise, but the same problems occurs with other versions (VS 2010, VS 2012, VS 2012).

    Do you install different VS versions in the same machine? Please make sure that it is not the performance issue.

    Please also install the VS2015 update 1, or you could repair your VS, check it again.

    To really make sure that whether it is the VS setup issue, we could collect the setup log:

    Please use http://aka.ms/vscollect  to gather the VS and .Net Frameowrk installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to Onedrive and share the link here.

    But if it is not the VS setup issue, I think we would think about the windows itself.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, March 11, 2016 8:06 AM
    Moderator

All replies

  • Hi Francesco,

    Since there has no problems on Windows 8 or previous, please check whether you have update your Windows 10 to latest version first.

    Then please remove ClickOnce to confirm whether it is really caused by ClickOnce or not. Then please run your Visual Studio in safe mode with "Deven.exe /SafeMode" command to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution. And please also close all other programs when running Visual Studio, which can exclude the effect from that programs.

    In addition, please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio. Whether there has any log information about Visual Studio hangs.

    Best Regards,
    Weiwei

    Wednesday, March 9, 2016 3:00 AM
    Moderator
  • thank you Weiwei,

    I tried to check the log, but, when VS hangs, no logs where flushed... and so no further informations are available in the log file.

    I'm sure that clickonce is related to the problem because my collegues have the same problem only when they work on a clickonce project (but only on Windows 10!).

    Thank you anyway.

    Francesco

    Thursday, March 10, 2016 9:29 AM
  • Hi Francesco,

    Just create a simple WinForm app, for example, just add a button to the UI, and then publish using the default options, does it still crash the VS?

    I just test it in my windows 10 machine, it works normally in my side.

    Like the above steps, if all WinForm apps have the same issue, I think we would think about the VS or the windows Environment. 

    (1) Reset your VS settings, and then create a new project, create the setup project again.

    (2) Please disable the VS hosting process in the project property.

    >>I'm using Visual Studio 2015 Enterprise, but the same problems occurs with other versions (VS 2010, VS 2012, VS 2012).

    Do you install different VS versions in the same machine? Please make sure that it is not the performance issue.

    Please also install the VS2015 update 1, or you could repair your VS, check it again.

    To really make sure that whether it is the VS setup issue, we could collect the setup log:

    Please use http://aka.ms/vscollect  to gather the VS and .Net Frameowrk installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to Onedrive and share the link here.

    But if it is not the VS setup issue, I think we would think about the windows itself.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, March 11, 2016 8:06 AM
    Moderator