locked
unable to open com port using serialcomm service RRS feed

  • Question

  • Hi guys ,

    I am actually working on robotic project. I want to communicate with my microcontroller (P89V51RD2) of robot . I have developed the following diagram. I configured it with the following settings . 

      Comport : COM4

       baud rate : 9600

      parity : none

       stop bits : one 

    The program is port open succesful. But i am unable to communicate with my port .

    is there anything more i need to do

    regards

    Bhavi


    • Edited by bhavi123 Thursday, August 9, 2012 6:33 AM
    Thursday, August 9, 2012 6:32 AM

Answers

All replies

  • Hi,

    To eliminate unknowns, can you confirm that the data does in fact get propagated all the way to SerialPortService?

    Also, not sure I know exactly what you mean by 'communicate with the serial port'. How do you know its not getting data?

    Saturday, August 11, 2012 12:27 AM
    Moderator
  • Hi Greg,

    Thanks for responding. I am actually using a robot kit. It contains red led's which blick when there is communication with serial port. I had written a separate program in c# using winforms . It worked but when it comes to vpl serial port . It is not working .

    bhavi

    Monday, August 13, 2012 4:23 AM
  • Can you attach another device to the serial port to validate the data is being received.  For some detailed instructions see the section "Testing with VPL" in the MSDN Magazine article Writing and Testing VPL Services for Serial Communication.

    Tuesday, August 14, 2012 4:21 PM
    Moderator