none
DevFC.exe stopped working

    Question

  • Hi i just upgraded to Windows Azure SDK 1.5 and when i try to debug the deploy crash with the message DevFC.exe has stopped working.

    The problem happen also on new projects

    Any Ideas?

    Thanks


    Touch the future with iBox. http://www.ibox-media.com/
    • Edited by Orangebit Friday, September 16, 2011 2:17 PM
    Friday, September 16, 2011 2:10 PM

All replies

  • Tha's make at least 2 of us!
    Saturday, September 17, 2011 8:12 PM
  • Just found this thread. That will be at least 3 of us.

    If you start from the notification icon, then do show UI it will crash. That's without VS2010 too.

    thanks

    Sunday, September 18, 2011 10:54 AM
  • I had to install the older version of the SDK to keep working


    Touch the future with iBox. http://www.ibox-media.com/
    Sunday, September 18, 2011 3:05 PM
  • Hi,

    I have reported this issue and I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay.

    Appreciate your patience.

     

    Best Regards,

    Ming Xu.


    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    Sunday, September 18, 2011 3:57 PM
    Moderator
  • Hi,

    I have reported this issue and I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay.

    Appreciate your patience.

     

    Best Regards,

    Ming Xu.


    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework

    Hi i don't know if it could help, but before installing the latest windows azure tools i had installed the Async CTP refresh, with the old azure the ctp din't interfere,i don't know if it ca be related, i have tried to uninstall the Asyn CTP  and the tools crash aniway.

     


    Touch the future with iBox. http://www.ibox-media.com/
    Monday, September 19, 2011 9:01 AM
  • I also have this problem. De compute emulator just don't starts.
    Monday, September 19, 2011 9:46 AM
  • I have exactly the same problem :'-( Never installed Azure stuff on this laptop before, so it shouldn't be because of old stuff. Let's hope there will be a fix soon...
    Monday, September 19, 2011 10:39 AM
  • Hi,

    same here. But it worked few hours back. Restarted my hp dv7 and hit f5 devfc.exe stopped working.  A little change what i did is before restart was clicked on "Don't show this dialog box..." on the azure progress box. 

    Hope there is quick fix soon.

    Regards,

    Manoj

    Monday, September 19, 2011 2:37 PM
  • I actually managed to fix this one on my machine! I looked in the logs (at C:\Users\Leon\AppData\Local\dftmp\DevFCLogs) and noticed that the Compute Emulator (or some related process) tries to create an endpoint on TCP port 120001:

    2011-9-19T11:4:34.236, 130, 1, Error, 201523225, Exception occurred when trying to open service host. {0}, {1}`There is already a listener on IP endpoint 127.0.0.1:12001.  Make sure that you are not trying to use this endpoint multiple times in your application and that there are no other applications listening on this endpoint.`   at System.ServiceModel.Channels.SocketConnectionListener.Listen()
       at System.ServiceModel.Channels.BufferedConnectionListener.Listen()
       at System.ServiceModel.Channels.ExclusiveTcpTransportManager.OnOpen()
       at System.ServiceModel.Channels.TransportManager.Open(TransportChannelListener channelListener)
       at System.ServiceModel.Channels.TransportManagerContainer.Open(SelectTransportManagersCallback selectTransportManagerCallback)
       at System.ServiceModel.Channels.ConnectionOrientedTransportChannelListener.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.TcpChannelListener`2.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.Dispatcher.ChannelDispatcher.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at Microsoft.Windows.Azure.Fabric.Cfx.Contracts.CommunicationFrameworkServiceHostBase`1.Open()
       at Microsoft.Windows.Azure.Fabric.Cfx.CommunicationFramework.CommunicationFrameworkServiceHost`1.Open()`

    On my machine this port was already taken by the 'VMWare Workstation Server' Windows Service (vmware-hostd.exe), which comes as part of VMWare Workstation 8.

    I stopped the VMWare Service using the Services Management Console and then I was able to start the Compute Emulator without any problems!

    Is there a way to configure that Compute Emulator to run on a different port?

    And a big thanks to Mark Russinovich (SysInternals) for Process Monitor, Process Explorer and TCPView tools. The tools that helped me track down this issue.

    • Proposed as answer by Covalence2011 Monday, September 19, 2011 8:53 PM
    Monday, September 19, 2011 3:33 PM
  • Interesting developments. I still can't get anything working. Tried various things.

    I don't have DevFCLogs directory in my dftmp directory, so that's not a help but i am running Win 7 on a VM Machine on Mac OSX. Never caused an issue previously.

    I do have DFAgentLogs but there is nothing in the logs that show it failing

    cheers
    paul

    Monday, September 19, 2011 4:08 PM
  • @pcurtis: I used SysInternals Process Monitor to find the location of the log files. Maybe you can do that too. You can also run TCPView and check if port 12001 is already occupied. You can run the tools directly from http://live.sysinternals.com
    Monday, September 19, 2011 6:39 PM
  • Had the same VMWARE conflict. This solved it for me.
    Monday, September 19, 2011 8:53 PM
  • @Covalence2011 Great!

    I would expect the emulator to show a nice error message box, not this ugly crash. Let's hope they fix this soon.

    Monday, September 19, 2011 9:07 PM
  • I have seen a suggestion that this problem may occur if there is a space in the name of the logged in user.
    Monday, September 19, 2011 10:32 PM
    Answerer
  • Could you find logs under folder:

    C:\Users\jslin\AppData\Local\dftmp\DevFCLogs

    C:\Users\jslin\AppData\Local\dftmp\DFAgentLogs

     

    We suggest to remove the previous SDK first and install the latest Azure SDK 1.5.

    One issues we confirm is: the Logon User name with space can't start the emulator.

    the workaround is:  Remove the space in the logon user or use the command line below

    dfservice -sp C:\temp –enableIIS

    Or  with conflict with  'VMWare Workstation Server' Windows Service (vmware-hostd.exe), which comes as part of VMWare Workstation 8.

    Since I can't repro this problem so far, If any one can upload one dumps to me, it can help me to find out the root cause.

    The detail steps as follow:
    1. Please download and install Windbg into C:\Debuggers directory.
    http://msdn.microsoft.com/en-us/windows/hardware/gg463012

    Install the Windbg base on your client version

  • Debugging Tools for Windows 32-bit Versions
  • Debugging Tools for Windows 64-bit Versions

    2. Please input following command in the Command Prompt ( run as administrator if we enable UAC)

    cd "C:\Debuggers" (the directory which you install the Windbg) first, then input
    following command
    ADPlus.exe -crash -pmn DEVFC.exe -quiet -o c:\temp
    The CDB.exe will attach to the DEVFC.exe process automatically.

    3. When crashed occur, CDB.exe will generate the crashed dumps file under your
    c:\temp directory.

    Please upload all dumps files to the following space:
    https://sftasia.one.microsoft.com/choosetransfer.aspx?key=05a65078-14e1-4391-b555-97cf9b8e3ef3

    Password is

    vVfsOO$K7NypMPD%

     

     

Tuesday, September 20, 2011 2:29 AM
  • I have created the dump file using the Debugging Tools. However, that upload space you provided must be one of the most tedious services Microsoft has provided me with, ever! The upload is very slow. I currently upload using the speed version, which required an ActiveX to be installed, but I get no feedback whatsoever on whether the upload is actually taking place. No progress bar, nothing... Let's hope the file arrives at your space...
    Tuesday, September 20, 2011 5:11 AM
  • @Jian Oh boy, the upload space you provided gave me so much trouble. After attempting multiple uploads using different methods it said the location could not be found!? I gave up on it and uploaded the files to a working upload facility. The upload took less than a minute!

    You can get the files here:

    http://wtrns.fr/oUNA9c9i5tnh03

     

    Tuesday, September 20, 2011 5:49 AM
  • I got the dumps and detail crash  information as follow:

    Hi LZandman,

    Sorry for the trobule and  I got your dump successfully.

    Base on the crashed dump and the problem due to follow information:

    Exception object: 0000000002909688
    Exception type: System.ServiceModel.AddressAlreadyInUseException
    Message: There is already a listener on IP endpoint 127.0.0.1:12001.  Make sure that you are not trying to use this endpoint multiple times in your application and that there are no other applications listening on this endpoint.
    StackTrace (generated):
        SP               IP               Function
        000000000017C670 000007FEE82CAECA System.ServiceModel.Channels.SocketConnectionListener.Listen()
        000000000017E710 000007FEE73AE778 System.ServiceModel.Channels.BufferedConnectionListener.Listen()
        000000000017E740 000007FEE73AC590 System.ServiceModel.Channels.ExclusiveTcpTransportManager.OnOpen()
        000000000017E830 000007FEE82D71B7 System.ServiceModel.Channels.TransportManager.Open(System.ServiceModel.Channels.TransportChannelListener)
        000000000017E8F0 000007FEE73CF768 System.ServiceModel.Channels.TransportManagerContainer.Open(System.ServiceModel.Channels.SelectTransportManagersCallback)
        000000000017E950 000007FEE73AE466 System.ServiceModel.Channels.ConnectionOrientedTransportChannelListener.OnOpen(System.TimeSpan)
        000000000017E9B0 000007FEE73E6292 System.ServiceModel.Channels.TcpChannelListener`2[[System.__Canon, mscorlib],[System.__Canon, mscorlib]].OnOpen(System.TimeSpan)
        000000000017EA00 000007FEE73C1684 System.ServiceModel.Channels.CommunicationObject.Open(System.TimeSpan)
        000000000017EAF0 000007FEE73CF428 System.ServiceModel.Dispatcher.ChannelDispatcher.OnOpen(System.TimeSpan)
        000000000017EB40 000007FEE73C1684 System.ServiceModel.Channels.CommunicationObject.Open(System.TimeSpan)
        000000000017EC30 000007FEE73A238F System.ServiceModel.ServiceHostBase.OnOpen(System.TimeSpan)
        000000000017ECA0 000007FEE73C1684 System.ServiceModel.Channels.CommunicationObject.Open(System.TimeSpan)
        000000000017ED90 000007FF0019F65A Microsoft.Windows.Azure.Fabric.Cfx.Contracts.CommunicationFrameworkServiceHostBase`1[[System.__Canon, mscorlib]].Open()
        000000000017EDC0 000007FF0019EE4E Microsoft.Windows.Azure.Fabric.Cfx.CommunicationFramework.CommunicationFrameworkServiceHost`1[[System.__Canon, mscorlib]].Open()
        000000000017EE40 000007FF0019EC63 Microsoft.Windows.Azure.Fabric.Cfx.CommunicationFramework.CommunicationFramework.StartService[[System.__Canon, mscorlib]](Microsoft.Windows.Azure.Fabric.Cfx.Contracts.CommunicationFrameworkServiceHostBase`1<System.__Canon>)
        000000000017EEB0 000007FF00190694 Microsoft.Windows.Azure.DevFabric.DevFabric.Main(System.String[])

     

    You can  use TCPView to check what process that is holding the port open.
    In normal situation: It shall be hold by the DEVFC.exe

    DevFC.exe 9076 TCP workwsx86 12000 workwsx86 0 LISTENING          
    DevFC.exe 9076 TCP workwsx86 12001 workwsx86 0 LISTENING          
    DevFC.exe 9076 TCP workwsx86 12002 workwsx86 0 LISTENING          
    DevFC.exe 9076 TCP workwsx86 15100 workwsx86 0 LISTENING          

    If other process occupied the ports and DEVFC.exe will crash due to the call stack above.

     

     

     

    Tuesday, September 20, 2011 6:02 AM
  • @Jian Li: Yes, so now you have confirmed exactly what I already have posted above :-)

    On my machine DevFC.exe wouldn't start, because of TCP port 12001 being occupied. In my case it was occupied by that VMWare service. User Covalence2011 had the exact same problem. So I guess we have now confirmed at least one issue that can cause this crash.

    When I stop that VMWare service all works just fine. However, I would like to be able to run both VMWare and the Compute emulator. So the big question remains: can the compute emulator be configured to run on a different port?

    • Edited by LZandman Tuesday, September 20, 2011 6:14 AM extra
    • Proposed as answer by Ed Staffin123 Friday, September 23, 2011 11:11 AM
    • Unproposed as answer by Ed Staffin123 Friday, September 23, 2011 11:11 AM
    Tuesday, September 20, 2011 6:12 AM
  • @LZandMan  Thank you for your quickly response, I check the DevFC.EXE.Config and I dont find any way to configure the port so far.

    I will check with product team and update you soon.

    Thank you for your patient.

     

     

     

     

    Tuesday, September 20, 2011 6:31 AM
  • @LZandMan

    Confirmed with PG and  Unfortunately there is no way to re-configure the ports used by devFC.exe so far.

     A solution is being worked on and it may fix in next release.  I am sorry about this and can you try to configure VMWare service ports?

    Tuesday, September 20, 2011 6:37 AM
  • Thanks, this was also the problem with me.
    Tuesday, September 20, 2011 6:48 AM
  • I've made some progress.

    It wasn't a port issue, my log files were clean of those kinds of errors. I enabled my administrator account and installed the SDK 1.5 under that. That didn't work for my main account (and i had changed the username to one word, no spaces). But if i run VS2010 within my administrator with a barebones project i managed to get the compute emulator to work. However because i set up my VS2010 in my main account (part of the administrator group) it hasn't quite installed everything correctly under administrator, specifically the storage side fails with issues to do with access to SQLSERVER.

    I looks like i may have to install everything under my Administrator from scratch to be sure now and in the future. A complete pain but perhaps developing under the administrator account is the best way?

    Unless we're expecting a newer version of the SDK so i can run under my normal user?

    Either way we need some serious error reporting additions - there is no indication anywhere in any logs i can find that the compute emulator failed under my other account

    cheers
    Paul

    Tuesday, September 20, 2011 9:50 AM
  • @Jian: I don't know if the VMware service can be configured to run under a different port. I've opened a topic on the VMware Communities for this issue. Maybe someone will help us there:

    http://communities.vmware.com/thread/329224

     

    Tuesday, September 20, 2011 10:41 AM
  • For me it must have been a permissions issue, perhaps with a space in the login name. I ended up enabling the built in administrator, uninstalling then reinstalling everything and it works now.

    I was running on a VMWare Fusion machine on a Mac, it was fairly easy for me to just rebuild everything as it was a VM dedicated to azure.

    But at the end of the day, it works now, whereas it didn't work in my named account, even once i'd removed the space.

    cheers

    paul

    Wednesday, September 21, 2011 8:47 AM
  • Brilliant! You're my hero! Great find.

    I realize it's just a work around, but at least it gets us off the time. I'm assuming this will get fixed my MSFT in short order.

    Let's hope so anyhow!

    I sure don't want to have to make a choice between VMware and Azure.

    Thanks again for the sleuthing.

    Ed

     

    • Proposed as answer by Ed Staffin123 Friday, September 23, 2011 11:10 AM
    • Unproposed as answer by Ed Staffin123 Friday, September 23, 2011 11:10 AM
    Wednesday, September 21, 2011 1:21 PM
  • Would be nice I you would mark my answer as being THE answer.
    Wednesday, September 21, 2011 5:19 PM
  • LZandman - doesn't look like THE answer to me, as I am not running any VMWare, but still have the original issue. Am rolling back to 1.4 in an attempt to keep going...

    Thursday, September 22, 2011 9:54 AM
  • @skid Solo: OK, maybe it's not THE answer :-) But it is certainly one of the answers, which is enough for it to be marked a such, I think.

    As for your problem: did you create a crash dump and send it to Microsoft, just as Jian described above? That should help them fix your problem.

    Friday, September 23, 2011 11:23 AM
  • On my machine, the HTC Phone software conflicted with de Azure Compute Emulator, because both applications run on local port: 12000. I have stopt the HTC software, and that fixed the error message
    • Edited by Dennis Waasdorp Monday, September 26, 2011 10:04 AM Missing context
    Monday, September 26, 2011 10:02 AM
  • YES! I also found the HTC Sync program running in background (which I was unaware of). Turned it off and no more problems...

    @LZandman - we're getting there!

    Thursday, September 29, 2011 11:09 AM
  • Stopping VMWare Workstation Server installed by VMWare 8 worked for me.
    Thursday, October 13, 2011 2:10 PM
  • I know this thread is old, but I did find the answer here:  (which had nothing to do with the IP ports)

     

    http://msdn.microsoft.com/en-us/library/windowsazure/hh472165.aspx

    Sunday, November 13, 2011 4:17 PM
  • Same issue for me stopping the service "VMWare Workstation Server" got it to work. I had the same message in the log file also.
    Richard Mitchell Project Manager Red Gate Software Ltd
    Tuesday, November 15, 2011 8:09 AM
  • i dont have any VMWare still issue.Tried all in the forum

    from event log

    Faulting application name: dfagent.exe, version: 6.0.6002.18312, time stamp: 0x4e9df235
    Faulting module name: ntdll.dll, version: 6.1.7600.16695, time stamp: 0x4cc7ab44
    Exception code: 0xc0000374
    Fault offset: 0x000c35e3
    Faulting process id: 0xb4c
    Faulting application start time: 0x01cd1319124f2280
    Faulting application path: C:\Program Files\Windows Azure Emulator\Emulator\devfabric\dfagent.exe
    Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
    Report Id: 51a85b90-7f0c-11e1-8fa9-e069952e7b91


    DFAgent Log

    [2012/04/05, 10:44:27.153,  INFO, 00003572] StorageRoot: C:\Users\Vivek\AppData\Local\dftmp
    [2012/04/05, 10:44:27.670,  INFO, 00003572] Unrecognized element 'webHttpBinding'. (C:\Users\Vivek\AppData\Local\Temp\Fabric.StockBindings.xml9ca8bae7-1bf8-42e7-a9b3-2e9c21411029 line 239)
    [2012/04/05, 10:44:27.683,  INFO, 00003572]    at System.Configuration.BaseConfigurationRecord.EvaluateOne(String[] keys, SectionInput input, Boolean isTrusted, FactoryRecord factoryRecord, SectionRecord sectionRecord, Object parentResult)
       at System.Configuration.BaseConfigurationRecord.Evaluate(FactoryRecord factoryRecord, SectionRecord sectionRecord, Object parentResult, Boolean getLkg, Boolean getRuntimeObject, Object& result, Object& resultRuntimeObject)
       at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
       at System.Configuration.BaseConfigurationRecord.GetSection(String configKey, Boolean getLkg, Boolean checkPermission)
       at System.Configuration.ConfigurationSectionCollection.Get(String name)
       at System.Configuration.ConfigurationSectionCollection.get_Item(String name)
       at System.ServiceModel.Configuration.ServiceModelSectionGroup.get_Bindings()
       at Microsoft.Windows.Azure.Fabric.Cfx.CommunicationFramework.Internal.Providers.ConfigurationProvider.LoadBindingConfiguration(ServiceModelSectionGroup svcModelConfig)
       at Microsoft.Windows.Azure.Fabric.Cfx.CommunicationFramework.Internal.Providers.ConfigurationProvider.LoadConfiguration()
       at Microsoft.Windows.Azure.Fabric.Cfx.CommunicationFramework.Internal.Providers.ConfigurationProvider..ctor(ICfxTraceSource traceSource, IConfigurationSource configurationSource)
       at Microsoft.Windows.Azure.Fabric.Cfx.CommunicationFramework.CommunicationFramework.Initialize(ConfigurationSourceType configurationSourceType, String configurationFileName)
       at Microsoft.Windows.Azure.Fabric.Cfx.CommunicationFramework.CommunicationFramework.Initialize(ConfigurationSource configSource)
       at main(Int32 argc, SByte** argv)

    Thursday, April 5, 2012 11:04 AM