locked
Error with tableadapter fillby query RRS feed

  • Question

  • I have a tableadapter with a fill,getdata() statements.

     

    I am trying to add a 2nd query that contains a WHERE Clause.

     

    When I try to execute the query in tableadapter configuration wizard (query builder), I get an error message:

     

    SQL Execution Error.

     

    Executed SQL statement:  SELECT ModuleID, [Desc], Inactive FROM tblModules WHERE (Inactive = [False])

    Error Source:  Microsoft JET Database Engine

    Error Message:  No value given for one or more required parameters.

     

    I don't have any parameters created.

     

    I also don't know why it's insisting on sticking the Desc field in square brackets.  I tried to remove them and I get another error.

     

    The fill,getdata() statement (original query) runs fine, and is identical, except there's no WHERE Clause.

     

    The 2nd query is a fillby.  It gives the same error whether there's a getdataby() or not.

     

     

    Friday, February 29, 2008 8:33 PM

Answers

  • Solved:

     

    Apparently True/False are not recognized values on a yes/no datatype in Access.

     

    When I changed the where clause to Inactive=0 then the query executed.

     

    Friday, February 29, 2008 11:13 PM