Yosemite - "failed to compile interface file" - Xamarin.IOS 8.2 - Xcode 6.1 RRS feed

  • Question

  • User60261 posted

    Hi guys,

    Today I updated my mac to Yosemite and also installed some updates on my Xamarin Studio. Since then, I'm not able to compile my project and I'm getting this error "failed to compile interface file". Also, I can not open the storyboard on Xcode because I'm getting this error "(com.apple.InterfaceBuilder error -1.)". Which is the same error that I get on the Xamarin console. I have tried downgrading my Xcode to the 6.0.1 version and targeting my Xamarin studio project to IOS 7.2, 8.0, and 8.1 but I still get this error.

    Anybody has any idea about what is happening?. Before the updates everything was working fine.

    Thank you,

    Friday, October 17, 2014 10:13 PM

All replies

  • User36851 posted

    I have this same problem. Oddly, I had it building successfully on Yosemite until I performed a clean rebuild on the project, at which point I started getting the same error as above. I have tried to open the storyboard file in Xcode and it directs me to look at the console output (but there is none). I am at a loss for how to resolve this.

    Can we get a resolution or at least some clarification from the Xamarin team on this?

    My error is as below.


    "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator8.0.sdk" 2014-10-19 12:35:32.881 ibtoold[16338:983325] Exception raised while unarchiving document objects - -[NSTaggedPointerString getCharacters:range:]: Range {0, 10} out of bounds; string length 6 /* com.apple.ibtool.errors */ /[Path]/MainStoryboard.storyboard: error: The document "MainStoryboard.storyboard" could not be opened. The operation couldn’t be completed. (com.apple.InterfaceBuilder error -1.) Recovery Suggestion: Check the console log for additional information. ibtool exited with code 1 Build complete -- 1 error, 4 warnings

    Sunday, October 19, 2014 1:38 AM
  • User36851 posted

    Ok, I actually managed to resolve this.

    In my case, there were two issues. First, the version numbers at the top of the storyboard were apparently not correct. Second, my storyboard (despite not being edited for over a week prior to this software update) had two duplicate scene entries within it.

    I resolved this by creating a new storyboard to get the correct version numbers, and then opening the xml of the original (non-working) storyboard, and carefully checked through, moving all of the entries into the new storyboard. Then I copied the entire contents of the new storyboard back into the original one and, phew, it works.

    Hopefully you can resolve in a similar manor, and Xamarin can update storyboard support so this doesn't happen again!

    Sunday, October 19, 2014 2:39 AM
  • User60261 posted

    Unfortunately, I had to revert all the updates, which means that I downgraded to Mavericks and Xcode 5. It was such a huge mistake to update to Yosemite.

    Sunday, October 19, 2014 5:53 AM
  • User6140 posted

    Guys... Has anyone identified the root cause of this? I have an application of around 50 views, there is no way to identify from which PNG its originating from. Can Xamarin engineers respond to this thread???

    Wednesday, October 22, 2014 5:47 PM
  • User64682 posted

    Ok, this one I solved it by removing the imageView referencing *.PNG images. For some reason it didn't like that. Now it compiles and doesn't throw this error anymore. May have something to do with XCode 6.1?

    Wednesday, October 22, 2014 8:24 PM
  • User64682 posted

    Ok, scratch the last comment. Although it does work but that wasn't the actual problem. I had my images in an Image folder that started causing the problem.

    I moved my PNG images to the "Resources" folder, re-referenced them and all compiled and started to work. So just moving the images to Resource folder is all was needed as far as I can tell.

    Wednesday, October 22, 2014 8:56 PM
  • User14795 posted

    If you have a path statement in your image interface control then it will fail. You need to remove all image path statements and put the images in you resources folder. It sucks and Apple has stated that this is way it should be done from here on out.

    Thursday, October 23, 2014 2:16 PM
  • User64682 posted


    So now we know.

    Thursday, October 23, 2014 9:14 PM
  • User29221 posted

    Exactly. I have same problem and resolved it with solution of GeoRover.

    Thursday, December 11, 2014 3:42 PM