locked
Visual Studio 2013 Ultimate Preview - Error Adding Database Project to LightSwitch Solution RRS feed

  • Question

  • Anyone run into an issue of getting an error when adding a database project to a LightSwitch solution in VS2013 Preview?

    Here's the error I get:

    The OutputPath property is not set for project 'Database1.sqlproj'.  Please check to make sure that you have specified a valid combination of Configuration and Platform for this project.  Configuration='Debug'  Platform='MCD'.  You may be seeing this message because you are trying to build a project without a solution file, and have specified a non-default Configuration or Platform that doesn't exist for this project. C:\Program Files (x86)\MSBuild\12.0\bin\Microsoft.Common.CurrentVersion.targets

    Any ideas?


    PP

    Monday, July 8, 2013 11:23 PM

Answers

All replies

  • Please right-click on the Solution in Solution Explorer, select Configuration Manager..., and ensure that the Active Solution Platform is "Any CPU" and that all projects related to the LightSwitch project (including the Database1.sqlproj project) have a Platform setting of "Any CPU". For some reason, your environment is setting one of these to "MCD" or is defaulting it to "MCD" when the platform is not set explicitly.

    Justin Anderson, LightSwitch Development Team

    Tuesday, July 9, 2013 1:53 AM
    Moderator
  • Hi Justin,

    I tried that, and I still receive the error. It seems to only occur *after* I update the LightSwitch project properties to use the newly added database project (after setting the SQL Database Project setting). I can add the db project to the solution, but when I update LightSwitch to use the db, I get the error and can't build.

    Paul


    PP

    Tuesday, July 9, 2013 11:34 PM
  • Hi Paul,

    This sounds like it could be your problem: Nasty Visual Studio Platform='MCD' Error in Visual Studio 2010 RC.  Could you try deleting the PLATFORM environment variable and see if that fixes it for you?

    Thanks,
    Chris Rummel

    Monday, July 22, 2013 10:16 PM
  • NAILED IT!

    Thanks Chris. Seems it was that silly factory set variable after all.

    Cheers!

    Paul

    Tuesday, July 23, 2013 2:49 AM
  • Hi I have this same issue with the new vs, could you please explain how you delete it and where you find it?
    Tuesday, October 22, 2013 7:15 PM
  • First open up the Control Panel and select the System item.  Then go to Advanced System Settings:


    Click on the "Environment Variables" button and you'll get this window:


    Find a variable named "Platform", then click on "Delete", "OK", "OK".  You might have to log out of Windows and log back in to get the change to take effect.

    Tuesday, October 22, 2013 7:28 PM
  • Thanks

    I also noticed another solution to my problem.

    I think I got this error because I added the databse project first and then the ligthswitch project second.

    I tried adding anew database project after I added the lightswitch project and the dropdown populated.

    Tuesday, October 22, 2013 8:17 PM