locked
request for permision of type 'System.Data.OracleClient.OraclePermition'... failed RRS feed

  • General discussion

  • Hello,

    I am using in my application System.Data.OracleClient. On all the client PC the application is working fine except one where I am getting the following message:

    Request for permision of type 'System.Data.OracleClient.OraclePermition, System.Data.ORacleClient, version=2.0.0.0, Culture=Neutral, PublicKEyToken=...' failed.

    I have checked that on this PC there is Oracle Client installed. How do I solve this problem?

    Thanks

    Thursday, November 22, 2012 5:02 AM

All replies

  • Hi Barbi,

    Welcome to the MSDN forum.

    Although OracleClient is on the approved assembly list, it makes its calls through OCI, which is native code and therefore UNSAFE. And remember, any access outside the SQL Server process is at least EXTERNAL_ACCESS. But the calls to OCI code is what makes this particular combination UNSAFE. Please refer to this page: http://social.msdn.microsoft.com/Forums/en-US/sqlnetfx/thread/89e3a792-5a7e-4e69-ada1-823df0fc9a9e

    Please try the solutions on these pages:

    http://social.msdn.microsoft.com/forums/en-US/adodotnetdataproviders/thread/95a31d76-a518-440b-aef3-b39d6c2f1399/

    http://social.msdn.microsoft.com/Forums/en-US/winformssetup/thread/34b8f21f-482d-42ad-bdaf-9b872a223e97

    Have a nice day.


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us

    Friday, November 23, 2012 7:47 AM
  • How is it bosible then on every pc everything to be fine, except on 1? Is it unsafe only on 1 pc or on all pc's where it is installed? how can it be safe for some and unsafe for another? how do I make it safe for all? Yes and this happens only if I run the application from the server, on a network drive. Localy it runs perfectly.

    Also, Alexander thanks for the reply, but before asking the questions I already have searched these forums and I have tried the links you have posted, you can see that I've already put the application localy but this is temporary solution. Can someone please post an answer without posting a link to a link to a link?

    Friday, November 23, 2012 8:00 AM
  • Are you running the application assembly from a network share? The exception is indicating that the app does not have sufficient permissions to load the assembly, so this is a problem with the trust settings on the machine.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Friday, November 23, 2012 2:09 PM
  • Yes Paul, I am running thris application from network share. From the client PC, localy it runs ok. But  I prefear to run it from network shate because of the updates of the program.
    Monday, November 26, 2012 5:21 AM