none
New-PSSession WinRM cannot process the request RRS feed

  • Question

  • Trying to connect exchange server 2013 remotely using powershell and getting following error pls guide
    thx.

    New-PSSession : [exch.mydomain.com] Connecting to remote server tdl-exch.tdl.com failed with the following error
    message : WinRM cannot process the request. The following error with errorcode 0x80090311 occurred while using
    Kerberos authentication: There are currently no logon servers available to service the logon request.
     Possible causes are:
      -The user name or password specified are invalid.
      -Kerberos is used when no authentication method and no user name are specified.
      -Kerberos accepts domain user names, but not local user names.
      -The Service Principal Name (SPN) for the remote computer name and port does not exist.
      -The client and remote computers are in different domains and there is no trust between the two domains.
     After checking for the above issues, try the following:
      -Check the Event Viewer for events related to authentication.
      -Change the authentication method; add the destination computer to the WinRM TrustedHosts configuration setting or
    use HTTPS transport.
     Note that computers in the TrustedHosts list might not be authenticated.
       -For more information about WinRM configuration, run the following command: winrm help config. For more
    information, see the about_Remote_Troubleshooting Help topic.
    At line:1 char:12
    + $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri ht ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
       gTransportException
        + FullyQualifiedErrorId : AuthenticationFailed,PSSessionOpenFailed
    PS C:\Windows\system32> $UserCredential = Get-Credential

    iffi

    Friday, October 21, 2016 7:37 AM

All replies

  • From my personal experience these normally mean 2 things.

    1. your credentials dont match up. you can also add the credential parameter to specific which credentials to use. otherwise it will use your local credentials.

    2. network issues. Make sure the following ports are open towards your exchange server (also used for mailbox migrations etc.)

    Port Protocol
    808 (TCP) Mailbox Replication Service uses to communicate
    53 (TCP) DNS
    135 (TCP) RPC End Point
    389 (TCP) LDAP
    3268 LDAP
    1024 > (TCP) if mailbox store is not statically configured then 1024 higher ports need to be open
    88 (TCP) Kerberos
    445 (TCP) Microsoft-DS Service
    443 (TCP)

    Mailbox Replication Proxy service uses port 443 to communicate with other Exchange 2010 client access server via HTTPS.

    3. make sure your mrs proxy service is enabled

    • Proposed as answer by IvoMaas Friday, October 21, 2016 8:20 AM
    Friday, October 21, 2016 8:20 AM