locked
HTTP Error 404.3 - Not Found RRS feed

  • Question

  • User1029841168 posted

    I got this message:

    HTTP Error 404.3 - Not Found

    Description: The page you are requesting cannot be served because of the Multipurpose Internet Mail Extensions (MIME) map policy that is configured on the Web server. The page you requested has a file name extension that is not recognized, and therefore is not allowed.

    I cannot seem to find MME? How to enable it?

    Regards,

    chanmm

    Monday, July 3, 2006 8:56 PM

Answers

All replies

  • User989702501 posted

    404.3 - MIME map policy prevents this request.

    What's the file extension of the request ? look at the IIS log entry.

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, July 3, 2006 9:06 PM
  • User1029841168 posted

    Dear Bernard,

    In my Windows\System32\Logfiles folder I only have HTTPERR but there is no W3Cxxx.log. This is the contain of the httperr1.log file.

    #Software: Microsoft HTTP API 2.0
    #Version: 1.0
    #Date: 2006-06-24 09:06:22
    #Fields: date time c-ip c-port s-ip s-port cs-version cs-method cs-uri sc-status s-siteid s-reason s-queuename
    2006-06-24 09:06:22 ::1%0 49307 ::1%0 80 - - - - - Timer_ConnectionIdle -
    #Software: Microsoft HTTP API 2.0
    #Version: 1.0
    #Date: 2006-06-26 09:55:43
    #Fields: date time c-ip c-port s-ip s-port cs-version cs-method cs-uri sc-status s-siteid s-reason s-queuename
    2006-06-26 09:55:43 ::1%0 49199 ::1%0 80 - - - - - Timer_ConnectionIdle -
    #Software: Microsoft HTTP API 2.0
    #Version: 1.0
    #Date: 2006-06-27 09:45:14
    #Fields: date time c-ip c-port s-ip s-port cs-version cs-method cs-uri sc-status s-siteid s-reason s-queuename
    2006-06-27 09:45:14 ::1%0 51043 ::1%0 80 - - - - - Timer_ConnectionIdle -
    2006-06-27 10:08:29 ::1%0 52077 ::1%0 80 - - - - - Timer_ConnectionIdle -

    Thanks,

    Regards,

    chanmm

    Tuesday, July 4, 2006 9:53 PM
  • User989702501 posted
    Nothing in IIS log? that's weird. How do you get http error code when you are not hitting the http server? what resource you are browsing? url?
    Tuesday, July 4, 2006 10:56 PM
  • User1029841168 posted

    Dear Bernard,

    This is what I got:

    Server Error in 'Default Web Site/WebPaging' Application.


    HTTP Error 404.3 - Not Found

    Description: The page you are requesting cannot be served because of the Multipurpose Internet Mail Extensions (MIME) map policy that is configured on the Web server. The page you requested has a file name extension that is not recognized, and therefore is not allowed.

    Error Code: 0x80070032

    Notification: ExecuteRequestHandler

    Module: StaticFileModule

    Requested URL: http://localhost:80/WebPaging/Default.aspx

    Physical Path: D:\inetpub\wwwroot\WebPaging\Default.aspx

    Logon User: Anonymous

    Logon Method: Anonymous

    Handler: StaticFile

    Causes:

    • The appropriate MIME map is not enabled for the web site or application

    Solution:

    • Verify that the MIME map is enabled or add the MIME map for the site.
      1. From the Web Management tool, open a connection to the website.
      2. Double click the MIME Types Management feature.
      3. Verify that the MIME type is in the list and is not set to Removed.
      4. If the MIME type is in the list and set to Removed, highlight the MIME Type in the list, and in the MIME Types Tasks, click Restore.
      5. If the MIME Type is not in the list, complete the MIME Type information in the Tasks pane under New MIME Type, and then click Add.
      NOTE: Make sure that this MIME mapping is needed for your Web server before adding it to the list.
    • Set up a new Failed Request Trace rule for this HTTP status code.
      1. Use the IIS Web Management tool to open a connection to the Web server where the problem is occurring.
      2. In the tree view, navigate to the Web site, and then click to select it.
      3. In the Tasks pane, click Failed Request Tracing.
      4. Check Enable Logging for this Site, specify a logging folder or use the default log folder, and then click OK
      5. Open the Failed Request Tracing Rules feature and click New Rule in the Tasks pane.
      6. Specify the content type to monitor and then click Next.
      7. Check the Status Codes checkbox, type 404.3 in the Edit box, and then click Next.
      8. In the Providers area, make sure that the WWW Server is checked and highlighted, and that in Provider Properties, the Verbosity level is set to Verbose.
      9. Click FinishRequest the page that generated the 404.3 error and then look at the tracing file that was created for the request. This file is located in the logging folder you specified in Step 4.

    More Information... This error occurs when the file extension of the requested URL is for a MIME type that is not configured on the server.

    Microsoft Knowledge Base Articles:


    Server Version Information: Internet Information Services 7.0.

    Thanks,

    Regards,

    chanmm

    Wednesday, July 5, 2006 12:52 AM
  • User989702501 posted

    It is showing staticfilemodule is handling the asp.net page, did you install the asp.net component ?
    Using the 'turn on or off windows features' make sure under:
    IIS - World Wide Web services - Applicaiton Development Feature - ASP.NET is selected.

    Wednesday, July 5, 2006 4:06 AM
  • User-1578401550 posted

    This is typically an ASP.NET (ISAPI/Classic mode) error.  You shouldn't see this message when using the integrated pipeline apppool.

    You may need to verify that ASPNET is enabled within the CGI/ISAPI restrictions in inetmgr.  To do this, simply open inetmgr, select your computer in the tree, and then look through the 'CGI/ISAPI restrictions' section.

    You can also do this via appcmd.exe. Change the path as needed :-)

    %windir%\system32\inetsrv\appcmd.exe set config -section:isapiCgiRestriction /.[path='D:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll'].allowed:true

    Please let me know if this helps!

    Thanks,
    - Jeff

    Friday, July 28, 2006 6:29 PM
  • User-232579728 posted

    Hi,

    I'm having the same problem here... Only I got it after installing .NET 1.1 on my Vista Build 5472. Service Packs and Security Patches didn't help the situation.

    Previous to .NET 1.1, IIS7 would serve .htm and .aspx as it's suppose to... However, now I'm getting the above error message when serving .htm and pages with "unformatted" contnet when serving .aspx.

    This also happened on my Vista Build 5456. Back then I uninstalled .NET 1.1, which damaged the installation totally. IIS7 simply refused to configure properly after that.

    Any clues?

    Thanks in advance,
       ...TC :-)

    Monday, August 14, 2006 10:55 PM
  • User-2026410440 posted
    sounds like your <handlers> collection may have gotten messed up.  Can you look in \windows\system32\inetsrv\applicationHost.config and see what you have configured in the <handlers> section?
    Tuesday, August 15, 2006 4:11 PM
  • User-1284108013 posted

    Incidently, logfiles are now in:

    %systemdrive%\inetpub\logs\logfiles

    Wednesday, August 30, 2006 4:02 PM
  • User279688547 posted

    Same problem as chanmmn. I checked everything suggested here. still not working.

    IIS serves html, but not aspx file.  I tried to look applicationHost.config, but not allowed to open.

    I am really frustrated with II7/Vista.. Where can I get help?

    Wednesday, April 25, 2007 12:46 AM
  • User1356161706 posted

    Computmate,

    Don't be frustrated. We will figure it out together :) 

    That you can't open applicationhost.config is caused by Vista's User Account Control feature.

    Here is what you do to open applicationhost.config:

    Click the "Start" menu - go to "All Programs" - "Accessories".

    Right click "Command Prompt" and select "Run as Administrator". Now you can open applicationhost.config.

    Just send me your %windir%\system32\inetsrv\applicationhost.config file. I can tell you what's wrong. My e-mail address is

    T H O M A D @ M I C R O S O F T . C O M

     

    Wednesday, April 25, 2007 2:32 AM
  • User146669634 posted

    Real Frustrated with Vista and IIS7!!!!!!!!****

    My .net v 1.1 refuse to work  PLEASE HELP!!!! 

    Server Error in Application "Default Web Site/PmsNetBeta"


    HTTP Error 404.3 - Not Found

    Description: The page you are requesting cannot be served because of the Multipurpose Internet Mail Extensions (MIME) map policy that is configured on the Web server. The page you requested has a file name extension that is not recognized, and is not allowed.

    Error Code: 0x80070032

    Notification: ExecuteRequestHandler

    Module: StaticFileModule

    Requested URL: http://localhost:80/pmsnetbeta/login.aspx

    Physical Path: C:\inetpub\wwwroot\PmsNetBeta\login.aspx

    Logon User: Anonymous

    Logon Method: Anonymous

    Handler: StaticFile

    Most likely causes:

    • It is possible that a handler mapping is missing. By default, the static file handler processes all content.
    • The feature you are trying to use may not be installed.
    • The appropriate MIME map is not enabled for the Web site or application. (Warning: Do not create a MIME map for content that users should not download, such as .ASPX pages or .config files.)

     

    Wednesday, May 9, 2007 6:02 AM
  • User146669634 posted

    My Log file says:

     

    #Software: Microsoft Internet Information Services 7.0
    #Version: 1.0
    #Date: 2007-05-09 09:33:42
    #Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status
    2007-05-09 09:33:42 ::1 GET / - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+1.1.4322) 200 0 0
    2007-05-09 09:33:42 ::1 GET /welcome.png - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+1.1.4322) 200 0 0
    2007-05-09 09:33:42 ::1 GET /favicon.ico - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+1.1.4322) 404 0 2
    2007-05-09 09:34:02 ::1 GET /pmsnetbeta - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+1.1.4322) 301 0 0
    2007-05-09 09:34:02 ::1 GET /pmsnetbeta/ - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+1.1.4322) 404 3 50
    2007-05-09 09:34:47 ::1 GET /pmsnetbeta/login.aspx - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+1.1.4322) 404 3 50
    2007-05-09 09:34:58 ::1 GET /PmsNetBeta - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+1.1.4322) 301 0 0
    2007-05-09 09:34:58 ::1 GET /PmsNetBeta/ - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+1.1.4322) 404 3 50
    #Software: Microsoft Internet Information Services 7.0
    #Version: 1.0
    #Date: 2007-05-09 09:43:04
    #Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status
    2007-05-09 09:43:04 ::1 GET /pmsnetbeta/login.aspx - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+1.1.4322) 404 3 50
    2007-05-09 09:43:24 ::1 GET /pmsnetbeta/login.aspx - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+1.1.4322) 404 3 50
    #Software: Microsoft Internet Information Services 7.0
    #Version: 1.0
    #Date: 2007-05-09 09:58:12
    #Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status
    2007-05-09 09:58:12 ::1 GET /pmsnetbeta/login.aspx - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+1.1.4322) 404 3 50
    2007-05-09 09:58:15 ::1 GET /pmsnetbeta/login.aspx - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+1.1.4322) 404 3 50
    2007-05-09 10:12:38 ::1 GET /pmsnetbeta/login.aspx - 80 - ::1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+1.1.4322) 404 3 50
    2007-05-09 10:15:12 fe80::a411:707e:5941:5e3f%8 GET /PmsnetBeta/login.aspx - 80 - fe80::a411:707e:5941:5e3f%8 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+SLCC1;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+1.1.4322) 404 3 50

    Wednesday, May 9, 2007 6:30 AM
  • User989702501 posted
    Have you try the suggested solution? asp.net installed?
    http://www.iis.net/default.aspx?tabid=2&subtabid=25&i=993
    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, May 10, 2007 2:03 AM
  • User146669634 posted

    Thanks for the help. IT WORKS...............................

     

    But now that Sybase Datawindows .NET printer is not working.... I cannnot install a Acrobat Distiller Printer which I need for Printing...

     

    Thursday, May 17, 2007 7:18 AM
  • User-12150214 posted

    Check hot the following link, it solved my problem!

    http://www.aspnet35.com/Blog/post/2008/09/15/Stupid-error!-HTTP-Error-4043-Not-Found.aspx

    Tuesday, September 30, 2008 4:35 AM
  • User1262168560 posted

    Hi Thomad,

    I am having similar issue.

    I have developed WCF server and trying to host it into IIS7 in Windows 7 professional machine. I am able to compile the service w/o any error, but when I try to browse the service I am getting following error...

    HTTP Error 404.3 - Not Found

    The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

     

    Module StaticFileModule
    Notification ExecuteRequestHandler
    Handler StaticFile
    Error Code 0x80070032

    As mentioned in this post http://iweb.adefwebserver.com/Default.aspx?tabid=57&EntryID=34, I tried to run ServiceModelReg, it says I should be an admin on this box, I am already admin in this box.

    It would be really great if you can guide me how to resolve this problem....

    Thank you in advance.

    Regards,
    Shailesh
    shailshukla@yahoo.com

    Sunday, December 12, 2010 1:36 AM
  • User989702501 posted
    when you open the command prompt, right click on it and runas administrator to elevate the privileges
    Sunday, December 12, 2010 9:34 PM