none
Ubuntu VM Disk Failed After 4 days. RRS feed

  • Question

  • I recently set up a ubuntu server vm on windows azure using the stock ubuntu server 12.04 image. However, about 2 days ago, the server suffers a weird problem. The VM displays 99.9%wa in top and failed to restart. It eventually restarted after several tries. I also notice an random not-manually-triggered restart of the server after that. Today, the root file system (mounted at /) suddenly became "Read-only file system" Another problem is, all the server status graphs (DISK READ BYTES/SEC etc) can't be displayed in preview portal. Since, the server only runs nginx/mysql/php5-fpm and there are no changes before and after those problems occurred, I suspect it might be a vm host issues.

    [120863.672861] sd 0:0:0:0: [sda] Unhandled error code
    [120863.672870] sd 0:0:0:0: [sda]  Result: hostbyte=invalid driverbyte=DRIVER_OK
    [120863.672880] sd 0:0:0:0: [sda] CDB: Write(10): 2a 00 00 00 76 b9 00 00 10 00
    [120863.672899] end_request: critical target error, dev sda, sector 30393
    [120863.675211] Buffer I/O error on device sda1, logical block 1791
    [120863.677220] lost page write due to I/O error on sda1
    [120863.677247] Buffer I/O error on device sda1, logical block 1792
    [120863.677571] EXT4-fs error (device sda1) in ext4_reserve_inode_write:4475: Jo
    urnal has aborted
    [120863.681946] lost page write due to I/O error on sda1

    Wednesday, August 29, 2012 6:55 PM

Answers

All replies