none
Disable windows Authentication after SharePoint SSO Azure AD login RRS feed

  • Question

  • SharePoint on premises SSO using Azure AD working fine but after microsoft.com credentials verification, site give prompt to enter windows authentication. If i mark disable windows authentication from CA crawling becomes disable. Just i have to login with microsoft.com account.

    Any solution?


    • Edited by Sabee Sharif Friday, May 17, 2019 6:52 AM Have to add one more line
    Friday, May 17, 2019 6:51 AM

Answers

  • Hi Wendy,

    Thanks for giving me a way to think about this.

    Unfortunately i haven't implemented SSO for the SharePoint where it have web part with windows authentication. 

    Resolution:

    I resolved this by applying self signed certificate because request i was hitting is http and after authentication it redirects to https so it requires credentials again as http is not secure protocol.

    Again Thanks for your reply.

    Cheers;

    Sabeeh


    SharePoint Developer/Consultant at Microsoft Partner Firm

    • Marked as answer by Sabee Sharif Friday, May 24, 2019 7:34 AM
    Friday, May 24, 2019 7:34 AM

All replies

  • Hi Sabee,

    Please set "Automatic logon with current user name and password" for your IE browser. 

    What did you mean that crawling becomes disable? Please go to Search service application, set the default content access account to your microsoft.com account. Then crawl again.

    Thanks,

    Wendy


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, May 20, 2019 8:21 AM
    Moderator
  • Thanks. But you didn't understand my query:

    I have configured SSO on Premises SharePoint 2010 with Azure AD. Following are the steps i have performed:

    1: Created SSO SharePoint Application Azure Portal

    2: Configured Azure Portal for SSO by giving SharePoint on premises URL, URN etc

    3: Created Identity Provider in SharePoint using Power Shell script

    4: Created user in Azure AD

    5: Provide full control in SharePoint to newly created user on Azure AD

    Problem:

    When user hit sharepoint server url, it redirects to Microsoft login which is fine. I enter credentials with Microsoft domain it validates perfectly. After this i get prompt to enter windows credentials. :(

    I have to disable this prompt it only needs to be logged in via Microsoft account. what i am doing wrong?

    Regards;

    Sabeeh MCP and MCSE


    SharePoint Developer/Consultant at Microsoft Partner Firm

    Monday, May 20, 2019 8:59 AM
  • Hi Sabee,

    We are currently looking into this issue and will give you an update as soon as possible.

    Thanks,

    Wendy


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, May 21, 2019 9:29 AM
    Moderator
  • Thanks waiting please give me solution, i am badly stuck here. Thanks  

    SharePoint Developer/Consultant at Microsoft Partner Firm

    Tuesday, May 21, 2019 9:45 AM
  • Hi Sabee,

    Is there a web part which is using Windows Authentication on the Home page of your site collection?

    Please use Fiddler to track the request to check what happened in the process.

    Thanks,

    Wendy


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Thursday, May 23, 2019 8:29 AM
    Moderator
  • Hi Wendy,

    Thanks for giving me a way to think about this.

    Unfortunately i haven't implemented SSO for the SharePoint where it have web part with windows authentication. 

    Resolution:

    I resolved this by applying self signed certificate because request i was hitting is http and after authentication it redirects to https so it requires credentials again as http is not secure protocol.

    Again Thanks for your reply.

    Cheers;

    Sabeeh


    SharePoint Developer/Consultant at Microsoft Partner Firm

    • Marked as answer by Sabee Sharif Friday, May 24, 2019 7:34 AM
    Friday, May 24, 2019 7:34 AM