locked
Where to find 'Missing Marketing Icon' RRS feed

  • Question

  • User266526 posted

    hi I published an application to apple app store and I got a message which says that I'm missing marketing icon as I'm using iOS 11. where can I add this 1024X1024 png marketing icon in xamarin studio? I'm using xamarin studio 6.3

    Saturday, September 23, 2017 2:50 PM

All replies

  • User74 posted

    @MHDAmmar I believe this is in the app definition within iTunes Connect? I wouldn't expect this to be part of the binary upload.

    Monday, September 25, 2017 2:13 PM
  • User266526 posted

    @JohnHair said: @MHDAmmar I believe this is in the app definition within iTunes Connect? I wouldn't expect this to be part of the binary upload.

    Yes, this is true but not for iOS 11 as the warning message says.. from now on "App Marketing Icon" should be uploaded with the binary unfortunately

    Monday, September 25, 2017 4:49 PM
  • User74 posted

    I found this, maybe it will help? https://stackoverflow.com/questions/44565883/missing-marketing-icon

    Tuesday, September 26, 2017 8:05 AM
  • User37696 posted

    @MHDAmmar,

    There are some changes for iOS 11. Take a look here: https://developer.xamarin.com/guides/ios/platformfeatures/introduction-to-ios11/updating-your-app/#StoreIcon

    We are also in the process of updating that doc to make it clearer what has changed so please keep an eye on it today.

    Tuesday, September 26, 2017 2:36 PM
  • User266526 posted

    thank you JohnHair, but I found this link before and it is a solution for XCode only.. I'm looking for an Xamarin studio or VS solution

    Tuesday, September 26, 2017 4:32 PM
  • User266526 posted

    @JohnMiller said: @MHDAmmar,

    There are some changes for iOS 11. Take a look here:

    We are also in the process of updating that doc to make it clearer what has changed so please keep an eye on it today.

    Can't Wait for the update.. I have an app pending :neutral:

    Tuesday, September 26, 2017 4:35 PM
  • User142039 posted

    When will this be fixed in Xamarin? I use Xamarin, not Xcode nor VS.

    Wednesday, October 4, 2017 7:25 PM
  • User142039 posted

    No matter what I do that app store continues to tell me I am missing a marketing icon. It would really be nice if this stuff were synced up in Xamarin Studio no? When is this going to be taken care of? I have to constantly replace my icons over and over, archive for publishing, then submit to the app store again and again and again until it finally takes it. A flat out answer of exactly what your users need to do to handle the situation is what I would expect at minimum. Instead of leaving us doing what I do or scouring the web for some work around.

    Thursday, October 5, 2017 3:24 PM
  • User142039 posted

    @JohnMiller I looked at the link you posted and I am using an asset cat. Mine does NOT have a store icon at all, and looks nothing like what is posted in that link. I have tried updating but there are no available updates.... can anyone from Xamarin please clarify this? I am left with an app that can not be updated, uploaded.

    Thursday, October 5, 2017 4:10 PM
  • User482 posted

    I can confirm I am having the same issue on VS for Windows and VS for Mac, all latest builds. No matter what I include, the App Store wants a marketing icon. @JohnMiller

    Thursday, October 5, 2017 9:12 PM
  • User142039 posted

    Well since Xamarin doesn't have anything to say about it I'll post my solution which did actually work, it took quite some time to figure it out for me anyway. This is for Xamarin IOS, I don't know about other IDEs. First I saw the documentation and my Images.Xcassests looks nothing like what the link from John Miller said it should look like and yes I followed the instructions to a T, I even tried creating a new project same problem. Piss poor that they can't help out thier users at all... anyhow here it is.

    You will probably have to right click on your solution, and expand Display Options, then make sure show all files is checked. Expand your Images.Xcassests folder in your project, and expand your [Name].appiconset folder. Find Contents.json and double click it, it will open for editing. You'll need to add this here

    {
      "filename": "1024x1024.png",
      "size": "1024x1024",
      "scale": "1x",
      "idiom": "ios-marketing"
    }
    

    Where the filename is obviously just that, other than that the rest should be the same... NOTE depending on where you place this in your .json file you may need to add a comma after the last } if you do not you will get a strange error when trying to archive for publishing. I'm not sure if spacing makes a difference or the order of the labels so I put them in the exact same order with the exact same spacing as the other entries. If you have trouble with this solution lemme know I'll try to help you. Oh and obviously you must have the file you specify in your project... good luck!

    Friday, October 6, 2017 12:28 PM
  • User482 posted

    Hi @EdmundSecatore - Thanks for the complete and thoughtful reply. From VS 2017 it doesn't see to work. The 1024.png, non-Alpha image, doesn't appear in the IPA strangely. Here's a screen shot of the .app in the .ipa

    Saturday, October 7, 2017 7:00 PM
  • User482 posted

    In VS for Mac it's there in the editor, but not in the .ipa either.

    Saturday, October 7, 2017 7:19 PM
  • User482 posted

    SOLUTION::

    If you use Source Control, like TFS over at VisualStudio.com, the 1024.png will not be added by default to the ios.csproj file. That's the problem. The compiler works fine if the files are there in the file folders, BUT , if they are not in the ios.csproj, the tool that makes your .ipa will not include the file in the .ipa.

    RIght Click the folder (ios proj) /Resources and choose the option to "Include in Project" and make sure the 1024.png is there and included.

    Special thanks to @EdmundSecatore who I now own a coffee to.....

    Saturday, October 7, 2017 8:26 PM
  • User37696 posted

    @IanVink, @MHDAmmar, @EdmundSecatore

    Apologies the link lead to confusion. The image posted there is an image of Visual Studio for Mac. Visual Studio's looks like this:

    Adding a PNG file to this template will add the appropriate entry to the Contents.json file. Then, in the .csproj it's added like this:

    <ImageAsset Include="Resources\Media.xcassets\AppIcons.appiconset\Icon1024.png"> <InProject>false</InProject> </ImageAsset>

    I'm using Xamarin Tools for Visual Studio 4.7.9.5. If you notice something is not working as expected, please let me know the details of your version information and what steps didn't work. I'll make sure to get any documentation updated or issues filed for investigation.

    Note* In Xcode 9, there does seem to be a change when building an .ipa file in that it does not include the PNG files when using an Asset Catalog. Instead, they are included in a assets.car file. You can see a discussion about this in a bug filed for WatchOS.

    Monday, October 9, 2017 12:49 PM
  • User197661 posted

    Hello! I have the same problem, thing is I followed these instructions. I have editet Content.json aswell as csproj but Application Loader still complain. Any Ideas?

    Tuesday, October 31, 2017 7:05 PM
  • User236064 posted

    my solution was to download visual studio and compile my project. from there I managed to place the 1024 icon

    Monday, November 6, 2017 7:48 PM
  • User101903 posted

    I am able to place it in the asset catalog and I also see it in the .csproj file. However, when I build the .ipa file I don't see it in the package, nor do I see it listed in the info.plist. Is there a different place that I need to reference it as well?

    Tuesday, November 7, 2017 9:53 PM
  • User37696 posted

    @PaulCardon,

    You won't see the png inside the IPA. It's packed inside the assets.car file.

    Thursday, November 9, 2017 8:28 PM
  • User165435 posted

    I could not find a "standard" way to fix the 1024x1024 missing error for Watch apps. The only solution was to edit the Contents.json file in the .xcassets. Add the image to the folder and this entry to Contents.json and it will work:

    {
      "size" : "1024x1024",
      "idiom" : "watch-marketing",
      "filename" : "iTunesArtwork.png",
      "scale" : "1x"
    },
    

    PS: iTunesArtwork.png is the 1024x1024 image.

    Thursday, November 16, 2017 2:32 PM
  • User256432 posted

    Xamarin,

    I want the hours of my life back that have been spent on issues like this with your 'product'. Horrible.

    Monday, March 12, 2018 9:00 PM
  • User367590 posted

    I just opened the info.plist file and edited the location and removed the resources directory from the name. You can see the location in @JohnMiller post. I have read somewhere else that you need to move the assets file into the resources folder but that means that it needs to be moved every time a change is made. Seems simpler this way. :smile:

    This was all done in VS2017 on Windows 10.

    Sunday, April 22, 2018 8:53 PM