none
Top Link Bar - Unable to remove items from Top Link Bar RRS feed

  • Question

  • Hi,

    I have a Top link bar set on a SharePoint site. The child site displays the same navigation items as the parent site under global navigation. Here( on a child site) a calendar was created and this calendar is appearing on the Top bar navigation with other sub sites of Parent site.

    I am unable to delete this "RP SC Calendar". Clicking on "x" doesn't do anything. I've tried it on IE 11 and Chrome.

    Tuesday, November 3, 2015 8:39 AM

Answers

  • Removing it from Navigation will remove it from left navigation as well. I however have found the reason and fix (seems to be an expected behavior or more so; a bug).

    1.  If we add Navigation item as a Link, it shows in the Top link bar.

    2.  If we add Navigation item as a Link but under some heading, it will not show in the top link bar.

    3.  If we add Navigation item as a Heading, it will not show int he Top Link bar.

    • Marked as answer by IMSunny Friday, November 6, 2015 1:10 PM
    Thursday, November 5, 2015 8:24 AM

All replies

  •  

    Hi,

     

    Have you tried removing that link from navigation settings?

    Site Settings =>under Look and Feel => Navigation

    Navigation link is visible when SharePoint Server Publishing Infrastructure feature is activated.

     

    Thank you


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.



    Wednesday, November 4, 2015 9:08 AM
  • Removing it from Navigation will remove it from left navigation as well. I however have found the reason and fix (seems to be an expected behavior or more so; a bug).

    1.  If we add Navigation item as a Link, it shows in the Top link bar.

    2.  If we add Navigation item as a Link but under some heading, it will not show in the top link bar.

    3.  If we add Navigation item as a Heading, it will not show int he Top Link bar.

    • Marked as answer by IMSunny Friday, November 6, 2015 1:10 PM
    Thursday, November 5, 2015 8:24 AM
  • That did not work for me.

    The thing that worked for me was:
    1. Disabling Piblishing features - see this;

    2. Now you can remove top links from Edit links

    Wednesday, August 7, 2019 7:37 AM