none
EDIFACT Simple Doubt RRS feed

  • Question

  • HI Experts,

    I have a simple doubt over EDIFACT message processing.

    1.)I have deployed EDIFACT schema and created a rec location and send Location.

    used edireceive pipeline in rec port.

    So i dropped .edi and got .xml message in send port..Fine.

    2.) Now i have created a party and by configuring UNB2.1 and some basic stuff.

    I checked that my party is working fine..

    But my real problem here is even if i drop different unb2.1 values also, am getting the out put.

    How should i restrict the files only with correct values to pass through and throw error if UNB2.1 is different?

    Needed urgently please..

    Friday, March 21, 2014 2:51 PM

Answers

  • The first thing you should always do is disable the Fallback Settings.

    1. Right click on Parties.
    2. Choose EDIFACT Fallback Settings.
    3. Uncheck Enable Fallback Settings.
    4. Apply, OK.

    Now, any Party Resolution errors will appear in the Event Log.

    Same applies for X12.

    • Edited by Johns-305MVP Friday, March 21, 2014 3:14 PM completeness
    • Marked as answer by sandydv85 Friday, March 21, 2014 3:57 PM
    Friday, March 21, 2014 3:13 PM
  • I don't think disabling FallBack all together is the right approach!

    Instead do the following on your Receive Port:

    Set Authentication -> Keep messages if authentication fails (if you want unknown messages to be suspended)

    Set Authentication -> Drop messages if authentication fails (if you simply want BizTalk to discard unknown messages)

    Morten la Cour

    • Marked as answer by sandydv85 Friday, March 21, 2014 3:57 PM
    Friday, March 21, 2014 3:34 PM

All replies

  • The first thing you should always do is disable the Fallback Settings.

    1. Right click on Parties.
    2. Choose EDIFACT Fallback Settings.
    3. Uncheck Enable Fallback Settings.
    4. Apply, OK.

    Now, any Party Resolution errors will appear in the Event Log.

    Same applies for X12.

    • Edited by Johns-305MVP Friday, March 21, 2014 3:14 PM completeness
    • Marked as answer by sandydv85 Friday, March 21, 2014 3:57 PM
    Friday, March 21, 2014 3:13 PM
  • HI Boatseller,

    Thanks for your reply, it did worked...Great..But when i drop the wrong partner message, I got below error.

    Is this one a normal exception?

    A message received by adapter "FILE" on receive location "Receive Location2" with URI "C:\Projects\In\*.edi" is suspended. 
     Error details: An output message of the component "Unknown " in receive pipeline "Microsoft.BizTalk.Edi.DefaultPipelines.EdiReceive, Microsoft.BizTalk.Edi.EdiPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" is suspended due to the following error: 
         Error: 1 (Miscellaneous error)
    79: Fallback Settings for the edifact Protocol is in Disabled state..
     The sequence number of the suspended message is 1.  
     MessageId:  {3580C7A8-EFD5-4D68-BA94-65D635DBC6C8}
     InstanceID: {D4DC5D31-9C0E-46DB-BFB5-916D31882222}

    Friday, March 21, 2014 3:23 PM
  • That means the EDI Disassembler was not able to resolve the interchange to an existing Agreement.  Yes, the actual error text is slightly misleading.

    However, this is what you want to happen in these cases so yes, it is a normal exception case you have to correct.

    Double/triple check the Agreement settings.

    Friday, March 21, 2014 3:31 PM
  • I don't think disabling FallBack all together is the right approach!

    Instead do the following on your Receive Port:

    Set Authentication -> Keep messages if authentication fails (if you want unknown messages to be suspended)

    Set Authentication -> Drop messages if authentication fails (if you simply want BizTalk to discard unknown messages)

    Morten la Cour

    • Marked as answer by sandydv85 Friday, March 21, 2014 3:57 PM
    Friday, March 21, 2014 3:34 PM
  • Thanks Cour..It is working Fine...Thanks to you and boatSeller.....

    Friday, March 21, 2014 3:58 PM