locked
WebCamOperations missing from proxy in V1.0? RRS feed

  • Question

  • I know that V1.5 is imminent, and the CTP does not have this problem, but just for my own peace of mind can somebody please confirm that Microsoft.Robotics.Services.WebCam.Proxy is missing the WebCamOperations class in V1.0? I can't see it in the object browser.

    I am trying to connect to a webcam, and without an operations port to send messages to, I don't know how I can subscribe or query frames!

     

    Trevor

    Saturday, June 16, 2007 2:36 AM

Answers

  • Hi Trevor, we are fixing the issue with the sim webcam. so you dont have to keep sending it update messages.
    Monday, June 18, 2007 3:17 AM

All replies

  • I got a real webcam working by fudging a local copy of the WebCam.Proxy.WebCamOperations class. However, the simulated webcam still does not work on V1.0. It works in the CTP of 1.5, so I am going to give up on V1.0.

     

    Note to Microsoft:

    In a recent post it was noted that the simulated webcam does not automatically send updates when you subscribe to it. I have used a workaround for now where I check the service name to see if it contains "simulated" and if so I start a timer and poke the webcam service periodically with UpdateFrame requests. This works, but it is a hack. Please confirm that this problem will be fixed in the final release of V1.5, or if not then please tell us so in the release notes!

    The post in question is:

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1659177&SiteID=1

     

    Trevor

     

    Saturday, June 16, 2007 1:48 PM
  • Hi Trevor, we are fixing the issue with the sim webcam. so you dont have to keep sending it update messages.
    Monday, June 18, 2007 3:17 AM
  • Thanks George. I thought you would be, but I didn't want it to fall through the cracks :-)

     

    Trevor

     

    Monday, June 18, 2007 4:15 AM