locked
Sharepoint Site returns a blank page RRS feed

  • Question

  • Hi,

    I am working on a project with my professor and for it I need to set up SharePoint 2013.

    The installation process worked out fine. I created a new Application Pool, and also a Site collection associated with it.

    Central Admin page is working fine but when I try to open Site I created I get three login attempts and then a blank page is returned. I have seen many questions like this one and they advised to turn off Windows Authentication. I have turned off all the authentications and when I try to access the site I get no prompts asking for credentials but it still returns a blank page.

    When I try to access the same site from a different machine (no the server), I believe the page designer is supposed to come up. However, I get the SharePoint page saying "Working on it" and it stays there it does not go any further.

    PS: I am setting up a 2-tier farm.

    Thank You in advance.

     

    Monday, September 23, 2013 6:20 PM

Answers

  • Hi,

    Did you use the administrator account to login the site?

    You can use the administrator account to login the site, then check the permission of your account.

    Maybe your account has no permission to access the site, you can assign it Full Control permission, then check whether it works.

    Thanks & Regards,

    Jason

    Jason Guo
    TechNet Community Support

    • Marked as answer by JasonGuo Sunday, October 6, 2013 11:21 AM
    Wednesday, September 25, 2013 1:38 AM

All replies

  • Hi,

    According to your post, my understanding is that you got three login attempts before it loaded a blank page.

    For this issue, we can run the following power shell command to disable the LoopbackCheck.

    New-ItemProperty HKLM:\System\CurrentControlSet\Control\Lsa -Name "DisableLoopbackCheck" -value "1" -PropertyType dword

    You may have to restart the servers and will have run this from all of your SharePoint servers.

    You can also navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa in registry and create the dword32 for DisableLoopbackCheck, modify the value to 1.

    For more information: http://sp-vinod.blogspot.in/2013/03/disable-loop-back-check-in-sharepoint.html

    What’s more, we also can try creating a new web app in SharePoint Central Admin and see if you are able to access that site correctly.  If you are then the odds are that something went wrong during the provisioning of the original web app.

    There are some similar articles for your reference:

    http://www.harbar.net/archive/2009/07/02/disableloopbackcheck-amp-sharepoint-what-every-admin-and-developer-should-know.aspx

    http://iedaddy.com/2009/04/sharepointdisable-loopback-check/

    http://www.jeremytaylor.net/2010/05/24/sharepoint-disable-loopback-check-disableloopbackcheck-dword-in-registry/

    If you have any problems, please feel free to reply me.

    Thanks & Regards,

    Jason

    Jason Guo
    TechNet Community Support


    • Edited by JasonGuo Tuesday, September 24, 2013 8:34 AM
    • Proposed as answer by Sharath Shivarama Wednesday, September 25, 2013 2:51 AM
    Tuesday, September 24, 2013 8:27 AM
  • Hello and thank you for answering.

    I have tried what you told me, and unfortunately it didn't work.

    Now instead of having the "Working on it" when I access the site remotely I simply get "this site hasn't been shared with you".

    Thank You

    Wednesday, September 25, 2013 1:28 AM
  • Hi,

    Did you use the administrator account to login the site?

    You can use the administrator account to login the site, then check the permission of your account.

    Maybe your account has no permission to access the site, you can assign it Full Control permission, then check whether it works.

    Thanks & Regards,

    Jason

    Jason Guo
    TechNet Community Support

    • Marked as answer by JasonGuo Sunday, October 6, 2013 11:21 AM
    Wednesday, September 25, 2013 1:38 AM
  • Hi,

    The Disable Loopback check is the perfect thing to do.

    When you created the site, you would have given atleast one user ids, 1. Primary Site collection administrator.

    2. Seconday site collection administrator.

    Try to login using one of those accounts or the account which was used to install SharePoint.

    If you are getting access denied, it means that you are able to hit to sharepoint site successfully.

    Regards,

    Sharath


    sharath kumart shivarama

    Wednesday, September 25, 2013 2:54 AM
  • I had the same issue with my sites on all site collections under a web application.

    I tested the other sites in the other site collection and they were coming up ok.

    I checked the content database, took it off line and reset it, same issue. Checked log files, no errors in the log files, reset IIS and app pools same issue, checked permissions on the webapp in iis, same issue.

    Solution.

    Replaced the webconfig from yesterdays backup and it worked,

    a solution that was deployed to the web application and activated on the site collection must added some entries and corrupted the file

    Thursday, February 5, 2015 6:12 PM