locked
adding FCKeditor to an old Club version RRS feed

  • Question

  • User-1002638002 posted

    I'm using an older version of the Club Starter kit and want to add the Email components that I see in the latest version.  I'm getting an error with the FCKeditor when I copy over the two Email pages into the admin section.  What are the steps to adding FCKeditor to an older version.  I've added the dll to the bin, the FCK folder, but I can't seem to find any page declarations for it or anything else I should copy over.

     Any tips or help would be most appreciated. 
     

    Tuesday, October 30, 2007 9:44 PM

Answers

  • User-2058016573 posted

    I've got it working on several pages of the old version on my site.  I had a few issues on the implementation, which you can see over at Mr. Lunch's Forums starter kit "Suggestions" thread:  http://wonglepong.wgg.com/clubwebsite/Forum_Thread.aspx?th=48

    I can post any code you need here, just let me know.  It sounds like you have everything in place so far with the dll and FCK files, you just need to call it from the page correctly like this: 

    <%@ Register TagPrefix="FCKeditorV2" Namespace="FredCK.FCKeditorV2" Assembly="FredCK.FCKeditorV2" %>

     And then:

    <FCKeditorV2:FCKeditor ID="FCKeditor1" Value='<%# Bind("description") %>' ToolbarSet="Default" runat="server" BasePath="~/FCKeditor/" Width="550" Height="300px">
    </FCKeditorV2:FCKeditor>
     Let me know what errors you are getting and we'll try to get you sorted.
    Kevin
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, November 1, 2007 1:21 PM

All replies

  • User-1563988197 posted

    What error are you recieving, exactly??

    Wednesday, October 31, 2007 6:46 AM
  • User-1002638002 posted

    I'm getting:   Parser Error Message: Unknown server tag 'FCKeditorV2:FCKeditor' 

    Wednesday, October 31, 2007 4:19 PM
  • User-2058016573 posted

    I've got it working on several pages of the old version on my site.  I had a few issues on the implementation, which you can see over at Mr. Lunch's Forums starter kit "Suggestions" thread:  http://wonglepong.wgg.com/clubwebsite/Forum_Thread.aspx?th=48

    I can post any code you need here, just let me know.  It sounds like you have everything in place so far with the dll and FCK files, you just need to call it from the page correctly like this: 

    <%@ Register TagPrefix="FCKeditorV2" Namespace="FredCK.FCKeditorV2" Assembly="FredCK.FCKeditorV2" %>

     And then:

    <FCKeditorV2:FCKeditor ID="FCKeditor1" Value='<%# Bind("description") %>' ToolbarSet="Default" runat="server" BasePath="~/FCKeditor/" Width="550" Height="300px">
    </FCKeditorV2:FCKeditor>
     Let me know what errors you are getting and we'll try to get you sorted.
    Kevin
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, November 1, 2007 1:21 PM
  • User-1002638002 posted

    Thanks GnrlPatton, that seemed to do the trick!  I also then found the reference to it in the web.config:

     

    <system.web>
            <pages theme="ClubSite">
                <controls>
                    <add assembly="FredCK.FCKeditorV2" tagPrefix="FCKeditorV2" namespace="FredCK.FCKeditorV2"/>
                    <add tagPrefix="Club" namespace= "ClubStarterKit.Web"/>
                    <add tagPrefix="Club" namespace="ClubStarterKit.Web.Controls" />
                    <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
                </controls>

     Now, I'm just getting errors with not having the correct BLL files!  woohoo!  [:)]

    Friday, November 2, 2007 1:26 PM
  • User-2058016573 posted

    Glad to hear it's working!  What are the BLL files / errors?

    Kevin

    Friday, November 2, 2007 3:18 PM
  • User-1002638002 posted

     I'm trying to figure out the Settings.vb file in the BLL.  I really only want to add the e-mail functionality, and maybe down the road do a complete overhaul the club site.  I'm also having to convert the settings.vb to c#, which wasn't really a problem(http://labs.developerfusion.co.uk/convert/vb-to-csharp.aspx) but I'm getting hung up on anything with the Current prefix. 

    Saturday, November 3, 2007 12:59 AM