locked
Entities & data not visible in MDS explorer RRS feed

  • Question

  • I created a model and then added an entity via the Excel addin. 
    I can see there is data in this entity and can query it from excel.

    The issue is when i try to view the entity and data in MDS Explorer nothing shows up.
    There are some drop down menus, but they appear to expand behind the panel where the data would be shown, so i cant see if my entity is actually on the menu.

    Is this a silverlight issue or MDS issue and how can it be resolved?

    UPDATE: if i delete any empty entities in the model and then go to explorer, the entity with data is now first in the list and loads, so i can see the data.
    The issue is the menus (Entities, Hierarchies, collections, Explorer) in the Explorer window expand behind the panel that shows the entity details, and so i cant select the entity i want from the menu, as i cant see it!

    Is this really  a production ready product?


    Thursday, January 22, 2015 6:09 PM

Answers

All replies

  • Some additional informtion.

    -The issue is prevalent on a Windows Server 2012 machine running IE V 11.0.96000.17207, patched to KB2962872

    -The issue is not present on a Windows 7 machine running the same  IE version  (V 11.0.96000.17207, patched to KB2962872)

    So although my immediate issue is resolved, i dont know why this does not work on windows server 2012 with an identical version of IE Patched to the same level

    Friday, January 23, 2015 9:38 AM
  • Also, any suggestions for Winston on this one too?

    Thanks!


    Ed Price, Azure & Power BI Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Monday, January 26, 2015 8:57 PM
  • Winston, do you still need help with this?

    Thanks!


    Ed Price, Azure & Power BI Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Tuesday, February 10, 2015 5:30 AM
  • Winston, I think this is a bug. Can you log this on Connect?

    Thanks!


    Ed Price, Azure & Power BI Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Tuesday, February 10, 2015 5:32 AM
  • There is a cache in WebUI.

    The changes in excel will take sometime to shown up in web UI.

    You can force clear the cache.

    1. In the home page, there is gray link "Refresh cached information".

    2. Or just run iisreset.

    Thursday, February 19, 2015 8:53 PM
  • nothing to do with the cache and needing a simple refresh, its clearly a bug in how the UI is rendered.

    The menu containing the entities goes behind the iFrame that contains the data for the entity so you cant see it or click any of the entities. Defo a bug in some specific version of IE, or with some specific IE settings.

    Thursday, February 19, 2015 9:47 PM
  • Oh, I see.
    The Web UI request run in IE compatible model.
    You can either configuration on client side:
    In the IE, Add the web ui server in the setting->compatibility view settings.
    Or server side:

       <system.webServer>
        <httpProtocol>
          <customHeaders>
            <!--Enforce to run in IE 7 mode-->
            <add name="X-UA-Compatible" value="IE=7" />
          </customHeaders>
        </httpProtocol>
    .....
    Thursday, February 19, 2015 10:15 PM
  • Winston or Ed

    Any solutions for this issue? I am having the same problem.

    Thanks


    Garrett Edmondson

    Thursday, March 26, 2015 9:11 PM
  • Did you try my suggestion about IE compatible model
    Friday, March 27, 2015 6:40 PM
  • @Vincent

    Yes I tried IE compatibility. Only in the MDS Explorer UI are the entities and data missing. As a work around I installed another instance of the MDS website on a Windows Server 2008R2 and it works fine there. 


    Garrett Edmondson

    Friday, March 27, 2015 6:52 PM