none
EntityFramework with Oracle10g R2 RRS feed

  • Question

  • Hello,

    I would like to know whether entity framework supports Oracle 10g R2 or not.
    I have to develop  aspnet wep application with Oracle 10g R2 version, Shall i use Entityframework? if yes which one is best Code first or Database  first approach?

    Please advice

    Thanks
    senthil
    Monday, November 5, 2012 1:18 PM

Answers

All replies

  • Hi,

    Yes Entity Framework supports Oracle.


    Ovais Mehboob

    Tuesday, November 6, 2012 6:40 AM
  • Hi Senthil,

    Welcome to the MSDN forum.

    Entity Framework/LINQ is supported only by ODP.NET 2.112.3 / 4.112.3 and later shipped with Client 11.2.0.3 or ODAC 11.2 Release 4 (11.2.0.3.0), so Oracle 10gR2 shipped ODP releases do NOT support EF/LINQ. Please check this page: https://forums.oracle.com/forums/thread.jspa?threadID=2461061&tstart=0

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by Alexander Sun Thursday, November 22, 2012 6:44 AM
    Wednesday, November 7, 2012 2:08 AM
  • Please can you tell me the steps:

    I am using visual studio 2015 (4.5.1) , Entity Framework 6 and oracle 10.2 oracle as db.

    Also I am using database first approach.

    I have to create mvc application with entity framework by using oracle10g .

    Please give me steps to create such type of project.

    Thursday, October 20, 2016 7:03 AM