locked
Could not connect to the report server RRS feed

  • Question

  • I have created  SSRS reports using sql server 2012, those are works well but when i deploy the solution that time i get an error 

    "Could not connect to the report server http://myservername/ReportServer. Verify that the TargetServerURL is valid and that you have the correct  permission to connect to the report server.

    Please suggest me how to resolve this issue i lost more time on this problem.

    Thank You.

    Wednesday, January 29, 2014 2:53 PM

Answers

  • Anil,

    What permissions do you have on the report server and target directory you specified?  At a minimum you need "Manage Reports".  Double check your security.  Try navigating to the report server using the URL you configured in your deployment properties in Internet Explorer and make sure it works.  Try accessing report manager as well (i.e., .../reports).  Many time I see our developers mistype the information in their deployment properties.  We have also seen our Antivirus software interfere, but that could be seen when navigating using a web browser.  If everything is installed on your development computer (locally), you might need to run BIDS or Visual Studio as an administrator.

    • Proposed as answer by JJordheim Thursday, February 6, 2014 3:16 PM
    • Marked as answer by Alisa Tang Friday, February 7, 2014 1:02 AM
    Wednesday, January 29, 2014 3:13 PM
  • Hi Anil,

    As JJordheim posted earlier, if we have no permission to perform the action we may get the similar issue.

    If the issue is persist, the issue may be due to User Account Control (UAC). There is a similar issue, please refer to it.
    http://social.msdn.microsoft.com/Forums/sqlserver/en-US/24011d1c-e61f-4f47-b037-1056c29bef4a/could-not-connect-to-the-report-server-httplocalhost8080reportserver-verify-that-the?forum=sqlreportingservices 

    Regards,
    Alisa Tang


    Alisa Tang
    TechNet Community Support

    • Marked as answer by Alisa Tang Thursday, February 6, 2014 7:22 AM
    Friday, January 31, 2014 1:39 AM

All replies

  • Anil,

    What permissions do you have on the report server and target directory you specified?  At a minimum you need "Manage Reports".  Double check your security.  Try navigating to the report server using the URL you configured in your deployment properties in Internet Explorer and make sure it works.  Try accessing report manager as well (i.e., .../reports).  Many time I see our developers mistype the information in their deployment properties.  We have also seen our Antivirus software interfere, but that could be seen when navigating using a web browser.  If everything is installed on your development computer (locally), you might need to run BIDS or Visual Studio as an administrator.

    • Proposed as answer by JJordheim Thursday, February 6, 2014 3:16 PM
    • Marked as answer by Alisa Tang Friday, February 7, 2014 1:02 AM
    Wednesday, January 29, 2014 3:13 PM
  • Hi Anil,

    As JJordheim posted earlier, if we have no permission to perform the action we may get the similar issue.

    If the issue is persist, the issue may be due to User Account Control (UAC). There is a similar issue, please refer to it.
    http://social.msdn.microsoft.com/Forums/sqlserver/en-US/24011d1c-e61f-4f47-b037-1056c29bef4a/could-not-connect-to-the-report-server-httplocalhost8080reportserver-verify-that-the?forum=sqlreportingservices 

    Regards,
    Alisa Tang


    Alisa Tang
    TechNet Community Support

    • Marked as answer by Alisa Tang Thursday, February 6, 2014 7:22 AM
    Friday, January 31, 2014 1:39 AM