none
Exchange Online - WebClientReadFormQueryString issue RRS feed

  • Question

  • We're having an issue when trying to reach Exchange items using URL returned by the WebClientReadFormQueryString property exposed by the EWS interface. 

    We do follow the guideline described in MSDN (http://msdn.microsoft.com/en-us/library/microsoft.exchange.webservices.data.item.webclientreadformquerystring(v=exchg.80).aspx), however when opening URL in the browser one always ends up in the Inbox with no item selected.

    Is there a change to the way how the value returned by the WebClientReadFormQueryString property should be post processed or is there an issue with the 15.20.2814.022 version of the Exchange server?

    Any help would be appreciated.

    Tuesday, March 17, 2020 4:55 PM

All replies

  • Hi Arkadiusz Mazur,

    Based on your description, your issue is related to EWS API. Since Exchange Online forum mainly discusses and provide suggestions about Exchange Online issues, we will help you move this case to Exchange Server > Exchange Server Development forum. You will get more professional suggestions there. Thanks for your understanding.

    Regards,

    Joyce Shen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, March 18, 2020 2:26 AM
  • They should work okay as long as the Message your trying to access exits in the Mailbox, What do the URL your getting look like ? what have you set the Requested Server version to ?

    Cheers
    Glen

    Wednesday, March 18, 2020 5:10 AM
  • Hi Glen,

    I'm sorry it took so long for me to respond (we had some technical issues that disallowed me to access the company network).

    Problem solved. It turned out that we had some kind of post-processing in place that was cutting off portion of returned URL.

    Thanks for your help,

    Arek

    Thursday, April 2, 2020 5:26 PM