none
Azure Files Storage share cannot be mounted in local Windows 8

    Question

  • I followed the instructions to mount a file share using the file Explorer, also disabled all firewalls (router and local machine) for testing.

    I've got (German):

    Der Computer ist offenbar ordnungsgemäß konfiguriert, jedoch antwortet das Gerät bzw. die Ressource (xyz.file.core.windows.net) nicht.

    Means my share does not respond. How to continue to make use of the Azure Files Storage on my local Windows 8. Azure storage Location is Western Europe, the Windows in Germany.

    Please help.

    Thanks, Frank

    Thursday, October 8, 2015 11:17 AM

Answers

  • Hi Frank

    Windows 8 does support SMB 3.0 and the command you are using shall also be correct as you already verified from a Azure VM.

    So one possible reason is your ISP blocked TCP port 445, as Comcast did in United States. If that's the case, disable all firewalls on router and local machine won't help.

    Not sure if it is even feasible for you, but if there are different network service providers in your place, you may want try it.

    - Jason

    Thursday, October 15, 2015 10:33 PM

All replies

  • Can you verify if you are able to mount it using an Azure VM instead?
    Thursday, October 8, 2015 11:57 AM
  • Bruno,

    thank you for quick Reply. Yes, it works with a newly created Azure VM (same region Western Europe). As I remember the beta connectivity was limited. But now it's GA and should also work with any local on-premises computer. Generally right?

    Thanks, Frank

    Thursday, October 8, 2015 1:19 PM
  • Are you using SMB 3.0? According to the documentation, you can only mount file shares from an on-premise client app by using SMB 3.0. Hope this helps.


    Thursday, October 15, 2015 8:06 PM
    Moderator
  • Are you using SMB 3.0? According to the documentation, you can only mount file shares from an on-premise client app by using SMB 3.0. Hope this helps.


    Windows 8 supports SMB3.0. I had the same problem in my Windows 10 machine. Didn't have the time for deep troubleshooting but looking for similar threads in search engines you will see tons of people with the same problem. 

    Thursday, October 15, 2015 9:20 PM
  • Hi Frank

    Windows 8 does support SMB 3.0 and the command you are using shall also be correct as you already verified from a Azure VM.

    So one possible reason is your ISP blocked TCP port 445, as Comcast did in United States. If that's the case, disable all firewalls on router and local machine won't help.

    Not sure if it is even feasible for you, but if there are different network service providers in your place, you may want try it.

    - Jason

    Thursday, October 15, 2015 10:33 PM