locked
Some C++ settings are not being respected RRS feed

  • Question

  • I want to disable things like "Automatic brace completion", "Auto list members" and "Apply cut and copy commands to blank lines when there is not selection" (but not limited to).
    I can't do that because the settings are re-enabled sometime later and I'm not the one re-enabling them.  I think the settings should stick. Is this a known problem?

    Sunday, May 8, 2016 9:20 PM

Answers

All replies

  • Hi Joel_Z,

    >>I want to disable things like "Automatic brace completion", "Auto list members" and "Apply cut and copy commands to blank lines when there is not selection" (but not limited to). I can't do that because the settings are re-enabled sometime later and I'm not the one re-enabling them.

    It means that the two options are enabled again automatically even if you have disabled it, am I right?

    (1) Please make sure that whether other user also could access this machine and change the VS settings.

    (2)Do you use other VS2015 in other machines and sign in use the Microsoft account in the top right corner of the VS IDE? If yes, maybe you could check that whether it is related to the “Synchronized Settings” under Tools->Options->Environment.

    When you use the same personalization account to sign in to Visual Studio on multiple computers, by default your settings are synchronized on all computers.

    Reference:

    https://msdn.microsoft.com/en-us/library/dn135229.aspx?f=255&MSPPError=-2147217396

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, May 9, 2016 3:17 AM
  • Hi Joel_Z,

    >>I want to disable things like "Automatic brace completion", "Auto list members" and "Apply cut and copy commands to blank lines when there is not selection" (but not limited to). I can't do that because the settings are re-enabled sometime later and I'm not the one re-enabling them.

    It means that the two options are enabled again automatically even if you have disabled it, am I right?

    (1) Please make sure that whether other user also could access this machine and change the VS settings.

    (2)Do you use other VS2015 in other machines and sign in use the Microsoft account in the top right corner of the VS IDE? If yes, maybe you could check that whether it is related to the “Synchronized Settings” under Tools->Options->Environment.

    When you use the same personalization account to sign in to Visual Studio on multiple computers, by default your settings are synchronized on all computers.

    Reference:

    https://msdn.microsoft.com/en-us/library/dn135229.aspx?f=255&MSPPError=-2147217396

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Nobody is using my computer.

    I do not sign in with visual studio.

    Is this a known problem?

    Monday, May 9, 2016 5:50 PM
  • Hi Joel_Z,

    Open your VS as the admin, and then change the VS settings. Please still open your VS as the admin if you re-open it next time, how about the result?

    I couldn't repro it in my VS IDE, so maybe it is the account issue or others.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Tuesday, May 10, 2016 8:28 AM
  • Hi Joel_Z,

    Open your VS as the admin, and then change the VS settings. Please still open your VS as the admin if you re-open it next time, how about the result?

    I couldn't repro it in my VS IDE, so maybe it is the account issue or others.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    I followed your steps and found "Automatic brace completion" under Settings->Text Editor->All languages was ticked. Prior to closing VS, I had that un-ticked. Its reproduced twice in a row.

    I keep hearing you think I'm logged in somehow through visual studio. The synchronize setting remains disabled/un-ticked. 

    Further, I disabled the Automatic brace completion, deleted the autosaved settings files and then closed VS. A new file was automatically created and the xml shows this:

    <PropertyValue name="BraceCompletion">true</PropertyValue>

    I had not launched VS again. This means the setting is not being respected because its written as true when it should be false within VS's autosave file "AutoSave.settings"

    Will you validate this and check to see if this is a known issue?

    Tuesday, May 10, 2016 7:15 PM
  • Hi Joel_Z,

    >>I followed your steps and found "Automatic brace completion" under Settings->Text Editor->All languages was ticked. Prior to closing VS, I had that un-ticked. Its reproduced twice in a row.

    I think I misunderstood this issue before. I just change the "Automatic brace completion" for the specific language like C# or others, it was normally. But as you said that if I change it under "All Language", it really has an issue, if I re-open it after I disable that option, I will get the result like the following screen shot.

    If you got the same issue as mine, I agree with you, it would be a real issue.

    You can submit this feedback to Microsoft Connect feedback portal: http://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx,Microsoft engineers will evaluate them seriously. If you submit it, you could share me the link here, I will help you vote it.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, May 11, 2016 6:15 AM
  • Hi Joel_Z,

    >>I followed your steps and found "Automatic brace completion" under Settings->Text Editor->All languages was ticked. Prior to closing VS, I had that un-ticked. Its reproduced twice in a row.

    I think I misunderstood this issue before. I just change the "Automatic brace completion" for the specific language like C# or others, it was normally. But as you said that if I change it under "All Language", it really has an issue, if I re-open it after I disable that option, I will get the result like the following screen shot.

    If you got the same issue as mine, I agree with you, it would be a real issue.

    You can submit this feedback to Microsoft Connect feedback portal: http://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx,Microsoft engineers will evaluate them seriously. If you submit it, you could share me the link here, I will help you vote it.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    I was directed here for support and have put forth time and effort to prove there is a problem and its more than just automatic brace completion. That was one example. I don't want to be redirected somewhere else and spend even more time. Would you create the ticket for me please?

    • Edited by Joel_Z Thursday, May 12, 2016 5:59 PM
    Thursday, May 12, 2016 5:57 PM
  • Hi Joel_Z,

    I help you submit a feedback here:

    https://connect.microsoft.com/VisualStudio/feedbackdetail/view/2700277/some-vs-settings-are-not-being-respected

    If possible, you could vote and add your comment there.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, May 13, 2016 5:53 AM
  • After clicking sign in to post a comment, it does not sign me in (sign in is still shown) and I can't add a comment..
    Friday, May 13, 2016 8:16 PM