locked
Unable to upload files to the Blob after a certain limit on devStorage RRS feed

  • Question

  • Hi All

    I have an application that has been running successfully on the cloud, but now I wanted to replicate everything on my local machine, so I download my table and blobs (using Cerebrata Cloud Storage Studio). I could upload the table just fine, but the blobs (container) seems to be having some problem, it stops copying the files to the blob and says: 

    "Message: Server encountered an internal error. Please try again after sometime."

    My machine has a lot of space available (the files are 10MB-600MB and some 1500 files in all).

    It seems like that it stops after I have uploaded 3.5 GB of data. Any ideas what might be happening?

    Regards,

    Rakesh


    • Edited by raaka1 Friday, March 22, 2013 5:29 AM
    Friday, March 22, 2013 1:48 AM

All replies

  • Hi,

    Have a look at this thread about the issue during uploading a file to Blob with the same error. It was caused by the content length. Check if it helps you:

    http://social.msdn.microsoft.com/Forums/en-US/windowsazuredata/thread/10b5a937-b3b9-4c95-8d18-b3e9c7247d6d/

    Thanks,


    QinDian Tang
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, March 22, 2013 7:15 AM
  • Hi QinDian

    I did have a look at the thread earlier, but doesn't work for me. I tried to manually upload some random file (one that were there on cloud and some JPEG files) using Neudisic too, but I still keep getting the same message when the 3.5 GB (approx) limit is exceeded.

    Is it possible that the dev storage has a limit of files that can be uploaded?

    Currently I am uploading .tar file, if that helps.

    Regards,
    Rakesh.

    Friday, March 22, 2013 4:58 PM
  • Blob service supports a blob only upto a size of 2GB

    Check this link and section "Differences for BlobService"


    Mark Answered, if it solves your question and Vote if you found it helpful.
    Rohit Arora

    Monday, March 25, 2013 7:28 AM
  • Hi Rakesh,

    What version of the Storage Emulator are you using? Versions since 1.7 have no limit on the total size of blobs.

    Also, can you clarify what you're seeing exactly? You successfully upload blobs until you reach 3.5 GB, then all attempts to upload fail -- even with different blobs that otherwise would upload successfully. Is this correct?

    Thanks,

    Michael

    Tuesday, March 26, 2013 10:10 PM