none
Sybase.Data.AseClient.AseConnection Exception RRS feed

  • Question

  • Before I used this component connect the Sybase. It works in Windows XP, Visual Studio 2008. Now I work in Windows XP and Visual Studio 2010, When I run the program that I wrote before. I get an exception. THe information is:

    "TypeInitializationException was unhandled" and "The type initializer for 'Sybase.Data.AseClient.AseConnection' threw an exception'

    After go through online and make many tries, I think I need some help you this borad.

    thank you!

    chuang

     

     

    Friday, March 23, 2012 2:56 PM

Answers

  • We need some more detailed exceptions/inner exceptions to provide you solution as this exception can be for number of reason. My primary suspect is, Your Ace Driver is not installed properly or you may be using a 32 bit ace driver in a 64 bit system.

    A quick tip can be,

    Step1: Using utilgac install the sybase aseclient dl(Sybase.Data.AseClient.dll)l to gac.
    Step2: Project Add reference =>select Sybase.Data.AseClient.dll. 


    Lingaraj Mishra

    Saturday, March 24, 2012 5:55 AM
  • Hi chuang7,

    Welcome to MSDN Forum.

    Have you tried @Lingaraj Mishra's solution? Does it resolve the issue?

    Best Regards


    Allen Li [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by chuang7 Tuesday, July 10, 2012 1:34 AM
    Tuesday, March 27, 2012 2:18 AM
    Moderator

All replies

  • We need some more detailed exceptions/inner exceptions to provide you solution as this exception can be for number of reason. My primary suspect is, Your Ace Driver is not installed properly or you may be using a 32 bit ace driver in a 64 bit system.

    A quick tip can be,

    Step1: Using utilgac install the sybase aseclient dl(Sybase.Data.AseClient.dll)l to gac.
    Step2: Project Add reference =>select Sybase.Data.AseClient.dll. 


    Lingaraj Mishra

    Saturday, March 24, 2012 5:55 AM
  • Hi chuang7,

    Welcome to MSDN Forum.

    Have you tried @Lingaraj Mishra's solution? Does it resolve the issue?

    Best Regards


    Allen Li [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by chuang7 Tuesday, July 10, 2012 1:34 AM
    Tuesday, March 27, 2012 2:18 AM
    Moderator
  • The problem was solved.

    The problem was caused by: My code was written in 32 byte system(VS 2008). It was used by others with a 64 byte system(VS2010). By sourcesafe, I used it by getting latest version and I use VS 2010.

    The solution is that I let a friend  (64 byte system, VS 2010) do : 

    Get Latest Version and open it and I copied them to my machine. It works well now.

    Thank your help!

    Tuesday, July 10, 2012 1:45 AM
  • I have followthis step but still get the same problem. Anyone can help me? i have spent 1 day try to resolve this issues.. thanks in advance

    akois

    Wednesday, September 5, 2012 8:09 AM
  • Hi,

    You can try downloading the latest version for 64bits @ http://www.sybase.com/detail?id=1051287&elq=00000000000000000000000000000000

    Regards,

    Alejandro.

    Wednesday, October 3, 2012 9:23 PM
  • I have the same problem. ><

    which files will be copyed?

    Thank you a lot for your help.

    Friday, September 6, 2013 6:43 AM