locked
Webtest passes when it is executed alone but fails with load test RRS feed

  • Question

  • Hello ,

    One of my  web test is running successfully when its executed alone.

    But it is facing error when it is part of a load test.

    I am getting bellow error

    ---------------------------------

    Validation Rule Error ValidateResponseUrl 170 The value of the ExpectedResponseUrl property 'https://pfazprf01web01.pfaz.com/APF/UI/Bms/ReadOnlyWorklist.aspx' does not equal the actual response URL 'https://pfazprf01web01.pfaz.com/APF/UI/Exception/PremiseException.aspx'.  QueryString parameters were ignored. 

    Please help by suggesting a solution ?


    Abhisek Biswal

    Thursday, June 29, 2017 8:03 AM

Answers

  • The error message shows that the actual URL of the response contains "Exception/PremiseException". This strongly suggests that the request is faulty and the web site is returning an error message.

    Look in the "Browser" and "Response" tabs in the web test results viewer, expect to see more details of the error. Some web sites give very poor error messages (see note) so you may need to consult the web site developers or the server error logs.

    (Note: this is done for good security reasons, it reduces the amount of information shown to hackers.)

    Regards

    Adrian

    • Marked as answer by AbhisekB Friday, June 30, 2017 7:07 AM
    • Unmarked as answer by AbhisekB Thursday, July 6, 2017 2:21 PM
    • Marked as answer by AbhisekB Thursday, July 6, 2017 2:21 PM
    Thursday, June 29, 2017 8:20 AM

All replies

  • The error message shows that the actual URL of the response contains "Exception/PremiseException". This strongly suggests that the request is faulty and the web site is returning an error message.

    Look in the "Browser" and "Response" tabs in the web test results viewer, expect to see more details of the error. Some web sites give very poor error messages (see note) so you may need to consult the web site developers or the server error logs.

    (Note: this is done for good security reasons, it reduces the amount of information shown to hackers.)

    Regards

    Adrian

    • Marked as answer by AbhisekB Friday, June 30, 2017 7:07 AM
    • Unmarked as answer by AbhisekB Thursday, July 6, 2017 2:21 PM
    • Marked as answer by AbhisekB Thursday, July 6, 2017 2:21 PM
    Thursday, June 29, 2017 8:20 AM
  • The error message shows that the actual URL of the response contains "Exception/PremiseException". This strongly suggests that the request is faulty and the web site is returning an error message.

    [[Abhisek]] : The web test passes when it is run alone .It only fails when it is part of load test .

                         So what can be the reason here ? I am wondering is sole reason behind this related to the application which causes the failure due load or some is wrong with my scripts ? 



    Abhisek Biswal

    Thursday, July 6, 2017 2:25 PM
  • You need to explain much more about the circumstances of the failure(s). How many virtual users when it fails? How many of those tests fail and how many pass? Can you see any pattern in the load test results of which fail and which pass? What does the "Detail" panel of the load test results show when it is zoomed to show the whole test, how does it look if the "Highlight errors" is set to show failed tests in red?

    There are many reasons why the test might fail. As I wrote previously, look in the "Browser" and "Response" tabs in the web test results viewer, expect to see more details of the error. Also look at these tabs for the previous tabs.

    Regards

    Adrian

    Thursday, July 6, 2017 8:33 PM