none
Error during SQL 2014 install attempting to use MSA account

    Question

  • I have crafted unique MSA accounts for my SQL 2014 HA install. However when I attempt to bind the account during SQL setup I am advised that the account is not configured properly, or is not appropriate for this type of install. I have verified the account attributes to some extent. However I do not believe I have the account(s) bound to the specific hosts. Anyone have a issue in this regard. I am loading the HA test on SQL 2014 Ent Ed, Running on Win 2012 R2 Standard Ed. The AD level is Windows 2008. I apologize for ignorance. Thanks for any insight

    James McKee

    • Moved by jrv Wednesday, May 3, 2017 5:51 PM Better forum
    Wednesday, May 3, 2017 5:24 PM

All replies

  • This has nothing to do with Windows PowerShell, as this is a scripting forum. You may find better luck posting in the SQL Forums

    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/home?category=sqlserver


    If you find that my post has answered your question, please mark it as the answer. If you find my post to be helpful in anyway, please click vote as helpful. (99,108,97,121,109,97,110,50,64,110,121,99,97,112,46,114,114,46,99,111,109|%{[char]$_})-join''

    Wednesday, May 3, 2017 5:50 PM
  • Hi James,

    Could you please share the full error message to us when you using this account to install SQL Server?

    Best Regards,

    Teige


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, May 4, 2017 9:42 AM
  • Here is the error. I think my issue may be the assignment of the created MSA in powershell. I see the accounts properly and can interrogate them via powershell. However I do not see the reference to being assigned to a specific host like I believe I have completed. Install error follows

    TITLE: SQL Server 2014 Setup
    ------------------------------

    There are validation errors on this page. Click OK to close this dialog box. Review errors at the bottom of the setup page, then provide valid parameters or click Help for more information.

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    TITLE: Message Details
    ------------------------------

    Managed Service Account 'My Domain\HAPDCAGTACC$' provided for 'SQLSERVERAGENT' is either not valid, not linked to this machine or cannot be used for this setup scenario.

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    TITLE: Message Details
    ------------------------------

    The SQL Server service account login or password is not valid. Use SQL Server Configuration Manager to update the service account.

    ------------------------------
    BUTTONS:

    OK
    ------------------------------


    James McKee

    Thursday, May 4, 2017 5:18 PM
  • I was able resolve this.

    James McKee

    Monday, May 15, 2017 4:27 PM